Elive

Roadmap for version 3.0 Expand all | Collapse all

18% of 61 tasks completed. 53 open tasks:

FS#158 - Cinelerra won't launch under "tests" e17 Expand Collapse

Cinelerra won't launch for me using the latest e17 from the "tests" branch of the Elive repos (it has never launched, even when I tried
it under the default e17 from Gem).

When I try to run it, I get a small, transparent window in the upper
left corner of my screen. When I close that window, I get this error
message:

"Application Execution Error: Cinelerra stopped running unexpectedly.
There was no error message. An exit code of 1 was /usr/bin/cinelerra."

By the way, it does launch under e16, but with an error message about memory...


FS#174 - Kino does not capture Expand Collapse

Hi all!
I've try to capture whit kino, but give me this error:

WARNING: raw1394 kernel module not loaded or faliure to read/write /dev/raw1394!

what can i do?
thanx!!!


FS#262 - Wacom Expand Collapse

Made something nice to made working by default wacom devices in Elive


FS#286 - amsn SVN is now supporting audio-video conferencing and is very Expand Collapse

amsn in svn now supports audio conferencing as well as audio video calls.
also is very stable.
tested in ubuntulu


FS#293 - Gdebi should notice user when installing manually packages Expand Collapse

installing unofficial packages is a very bad practice, it can broke the system. We need to notice the user with a popup in gdebi about this issue.


FS#317 - Fonts for special languages not installed by default Expand Collapse

Looks like not all the fonts for special languages are installed by default (see google translator for chinese or japanese, or see also to configure hte language with langconf (characters not readable for some languages)), langconf should show ALL the caracters because i have made it one by one and i have read all of them

Could be need to try to install manually some font packages and see which ones are remaining, but WARNING, some fonts packages takes a LOT of space in hard disk and the size of the ISO is pretty limited, install just the ones that are needed, not waste space of the limited ISO size standard

Note: is possible that could be need to restart X after to install a font. Use the livecd mode better


FS#319 - eeepc brightness apci script should be linked to correct path! Expand Collapse

/etc/laptop-mode/conf.d/lcd-brightness.conf

+BATT_BRIGHTNESS_COMMAND="echo 3"
+LM_AC_BRIGHTNESS_COMMAND="echo 15"
+BRIGHTNESS-OUTPUT="/sys/class/backlight/eeepc/brightness"

this is the most up to date and correct link to be set up in laptop-mode tools.


FS#344 - limit windows to be in the screen Expand Collapse

Could be nice if we have an e17 module to limit the windows to be in the screen limits, instead to pass over it. This is a useful feature for non-experienced users.

Note: this report has somewhere (i dont remember where) a list of features needed, like which options to have on it (like: limit the windows to be in-screen, limit the windows to be not entirely out of the screen, allow the window to be partially out, etc etc), is needed to check this list first (in hackers or in dev ? i dont remember right now)

Useful code: iirk module


FS#345 - Popup information for windows Expand Collapse

Like it says in the review article http://news.softpedia.com/news/Elive-Compiz-104523.shtml , when you mouse-in around a window in the pager or the minimized applications, there's not a kind of popup information about "what" is that window, could be nice to add this feature ?


FS#365 - aMule has wrong configuration (download dirs) Expand Collapse

The default download directories of aMule are not userfriendly at all


FS#369 - OSS compatibility Expand Collapse

Games like Wolfenstein not works directly by default, made a compatibility for this, start by add a script to load all the snd-*-oss modules at the init of the system, then see if directly works or needs to run with "aoss" (not so nice way (userfriendly))

http://en.gentoo-wiki.com/wiki/Enemy_Territory

http://www.gentoo-wiki.info/TIP_ALSA_with_Quake3/Enemy_Territory


FS#379 - HandBrake Expand Collapse

HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded video transcoder, available for MacOS X, Linux and Windows. http://handbrake.fr/ Supported sources: * Any DVD-like source: VIDEO_TS folder, DVD image or real DVD (unencrypted--protection methods including CSS are not supported internally and must be handled externally with third-party software and libraries), and some .VOB and .TS files * Most any multimedia file it can get libavformat to read and libavcodec to decode. Outputs: * File format: MP4, MKV, AVI or OGM * Video: MPEG-4, H.264, or Theora (1 or 2 passes or constant quantizer/rate encoding) * Audio: AAC, MP3, Vorbis or AC-3 pass-through (supports encoding of several audio tracks) Misc features: * Chapter selection * Basic subtitle support (burned into the picture) * Integrated bitrate calculator * Picture deinterlacing, cropping and scaling * Grayscale encoding Would you please add this Programm to the Repos. Best Regards, FreeEagle


FS#384 - wifi link intel pro 5100 agn Expand Collapse

The intel pro 5100 wifi card doesn't work with Elive. There is an Intel driver : intel linux driver but I'm a newbie and I don't know how to install it ... Somebody can help me ? thanks!


FS#442 - eeepc-elive-scripts patch (camera not working) Expand Collapse

See diff for /etc/init.d/eeepc-elive-scripts:

#diff eeepc-elive-scripts.old eeepc-elive-scripts
23c23
< echo -n 1 » /proc/acpi/asus/camera 2>/dev/null

echo -n 1 » /sys/devices/platform/eeepc/camera 2>/dev/null

Reason: 2.6.26 and later kernel has moved /proc/acpi/asus to /sys/devices/platform/eeepc

I will check also other scripts, volume, brightness, etc...


FS#457 - Intel Wireless pro 5100AGN card not working Expand Collapse

problems getting Intel Wireless pro 5100AGN card working. According to all wiki the iwlagn module and mac8*** module required to run these cards should be built into the kernel but not there and for some reason elive doesn't allow its installation. The iwlagn module is different from the iwp module.


FS#462 - .xsession-errors Expand Collapse

.xsession-errors file of the home of the users, contains the logs of the X when they are running, this should be removed at every e17 startup


FS#463 - Power management Expand Collapse

Use only one power management daemon, maybe disable cpufreq of e17 and use only gnome-powermanager IF is a laptop ? maybe ask that ? maybe predefine selection by hardware specs ?


FS#465 - Request for 802.1x wireless authentification to be included in t Expand Collapse

PLEASE be describable, clear, and direct. Think that we need to understand, found, and solve the bug.

I would like to request that 802.1x authentification be added to the wireless network connector utility. The company where I work uses this mode of wireless authentification. It would be a great convenience to me at work, as I have to use a wired connection otherwise.


FS#484 - module slamr does not exist bug STILL EXISTS (not cured) Expand Collapse

Hi, sorry to have to report, I just tried to install (with a proven DVD download of E17 compiz) on a 2nd computer, Intel MB DG45FC. First problem was it would not recognize display resolution, I am using Mitsubishi Diamond Digital, wide screen (16 x 9) and factory default setting called for is 1280 x 768 at 60HZ—which is in listed choices upon installation, nor any other resolution including auto? This is a 64bit machine, I have the DVD installed OK, no problem, on a Gigabyte 32bit MB.

I kept trying, over and over and somehow was able to "force" installation after being given a choice to use a pre-existing resolution(?) Install completed, fine tune came up and stopped at: "module slamr does not exist in /proc/modules. Also, internet connect was not able to be made, no matter what I tried so I can make no correction through apt-get, Synaptic or .deb. I also got a notice that e17 economorph failed to install because of some file in libdecorate(?) was trying to overwrite an already existing file. Not being technically capable, I haven't a clue.

But please, do not fool yourself into thinking the slamr "bub" has been corrected and gone away, it is still there.


FS#487 - kernel added in grub when installed Expand Collapse

postinstall of kernel-image should call grub-aggregator from nurse


FS#489 - double wireless interfaces is not correctly managed Expand Collapse

When there's 2 wireless interfaces listed in NC, when you select one of them, NC comes back to the other one

Note: looks like there's also a problem related with the scanning, like too much fast scannings etc
Note: somebody has reported me that if you put your password and between you are doing this the list is scanned (updated), your password is removed


FS#494 - Installing crossover games causes X server/enlightenment to hang Expand Collapse

Installing Crossover Linux (both Pro and Games) from CodeWeavers causes either enlightenment or Xorg to hang or crash.

When the install is finishing up Xorg/enlightenment freezes, mouse can be moved, but nothing happens - and I am unable to change to another desktop using CTRL + ALT + arrow key

The same thing happens when trying to install applications or managing bottles. Though sometimes I get an error message that enlightenment has SEGV'ed with the options to Recover or Quit.

I think it might be when Crossover tries to generate menu links for the application, but I am not entirely sure.

I am sorry to say that this used to work under Ubuntu/enlightenment.

You can download a trial of Crossover Games here:
http://www.codeweavers.com/products/cxgames/download_trial/

(This is important for gamers - hence the severity)


FS#497 - OSD volume menu Expand Collapse

Nice feature, as other distros have this, is to see OSD menu with volume settings, as also M$ does have..


FS#504 - MSI 5200le onli 640x480 resolution avaliable Expand Collapse

Elive cant mannage this video board, msi5200le (nvidia), no way to make it work in higher resolution than 640x480


FS#505 - 1.9.42 compiz - wlan0 .... kernel panic!! RTL-8185 Expand Collapse

1.9.42 compiz live cd cant boot up, the machine get frizzed with this error msg on screen:

Network device wlan0 detected, DHCP broadcasting for ip. [ 40.783723] Kernel panic - not syncing: HwthreeWire() CmdReg: 0XFF RE|WE bits are not clear!!
[40.783727]

I have to say that on 1.0 this realtek (RTL-8185) pci wifi board didnt work (the system did not recognized it), but livecd have been loaded ok, the instalation was ok, and the system was full working
On 1.9.50 / 51 the wifiboard works perfectly


FS#512 - Protected EAP (PEAP) network authentication support? Expand Collapse

Hi

Just wondering if there is a way to get elive to access a wireless network using Protected EAP (PEAP) as WPA authentication.

I have installed FreeRadius from synaptic but don't know how to configure it.


FS#513 - Wifi problem on Dell D410 Expand Collapse

Hi,
I use elive installed on a Dell D410 laptop with Broadcom BCM4311 wifi card. I can see networks, but I'm unable to connect to anyone because dhclient is unable to obtain an IP address.
I tried other wifi cards (Realtek, D-Link), and it is always same problem. All these cards are supported by Debian Lenny or Ubuntu 8.04.
I really like elive and wouldn't go back to Lenny because of this wifi problem.

Thanks for help.
G. Hatt

uname -r:
2.6.26.8-elive-686

lspci :
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
01:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
02:01.0 CardBus bridge: Texas Instruments PCI6515 Cardbus Controller
02:01.5 Communication controller: Texas Instruments PCI6515 SmartCard Controller
02:03.0 Network controller: Broadcom Corporation BCM4311 [AirForce 54g] 802.11a/b/g PCI Express Transceiver (rev 02)


FS#515 - Some Feature-Requests Expand Collapse

Hi!
Today I'm posting things I noticed during last weeks that might need some Improvement:

-Streaming Sound via Bluetooth without manually setting pcm-device=bluetooth

-Thumbnail-Preview for iBox

-Lowering default Startup-Sound volume in LiveCD

-Mention Intel-Mac-ONLY on website!!

Thanks.

alex
:)


FS#533 - ican't remove ICEWEALS Expand Collapse

Hello,
i cna't remove iceweals,
if i remove it on the synaptic or on the command line, all major importa packetage of Elive is gone :'(

img42.imageshack.usimg42945777993696.jpg

and u can see on the picture
i have firefox, and i need to clik on the link and iceweals is lunch and bug, and i need when i click on the link on xchat or other program, go on firefox and not lunch iceweals.

thanks for u patient


FS#541 - Enlightenment SEGV while changing resolution Expand Collapse

When trying to change resolution screen goes black and a box appears showing that Enlightenment SEGV'd.

To reproduce this bug please boot Elive from a CD, selecting automatic resolution. After full boot up enter Settings Panel/Screen/Resolution and choose some other resolution and frequency but do not save your selection, just click "restore" button and then change frequency again. Now this crash should happen.
I supose this behaviour is easier to reproduce using CRT display.

My guess is that this SEGV happens because when you mark resolution and frequency for the first time and cancel, the choice of resolution is not remembered, but you are still able to choose frequency and try to set it.

My rig has GeForce 5700 FX and thus uses nvidia 173 driver.


FS#542 - tick mark in Screen Resolution Setting box is not being updated Expand Collapse

After changing resolution or frequency with the Screen Resolution Setting box the tick mark doesn't change it's place. However it marks the proper option after closing and reopening this box.


FS#554 - 2.0 : scrolling disabled with touchpad Expand Collapse

Version 2.0 new kernel Topaz

laptop Dell Vostro13, touchpad synaptics, gsynaptics 0.9.14-6 installed

No scrolling at all with the touchpad (vertical, horizontal...)

tap is ok (double tap= 1 click)

It seems that's it doesn't work at all, when I try to load the touchpad menu, I get :
"Synaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics"

I've added these lines to the xorg.conf file, and also a shmconfif in hal (like in this doc : http://doc.ubuntu-fr.org/touchpad ...in french), reloaded the system and nothing (the ibar only disappear the 1st time...)

saw on some boards it could be a problem with the kernel (?)


FS#555 - volume still setup to 100% after first install of Topaz Expand Collapse

After upgrade system from ISO the volume setup to 100% - too loud for the first time..


FS#556 - Upgrade system feature request Expand Collapse

The needed "features" for upgrading system from ISO (CD or HDD ISO):

- let the gadgets be as they were before
- let the background be as it was
- lost the hotkey setup from the keyboard shortcuts made by myself
- lost the installed applications, they're still on HDD but they're not installed


FS#557 - Unexpected end of editing features - F1 recovery E17 error Expand Collapse

If U end some dialogs from setup panel without exit as expected - for example not to wait for EXIT button and end it with close window or ESC, there is E17 error appeared..


FS#558 - Better Volume Control Expand Collapse

It would be nice to have better volume control uupon installtion. Maybe a switch on the desktop or better support for laptop volume hotkeys.


FS#559 - hibernate wake-up problem Expand Collapse

some problem with USB appeared after trying to wake up from hibernate.. Enumerate USB or something.. ?
System wont launch and the text with error report is running on the screen..


FS#563 - vpn ad-hoc Expand Collapse

No funciona la conexión punto a punto
Thank you


FS#567 - printer applet autorun Expand Collapse

When the printer is plugged, run the printer applet and when is unplugged, remove it


FS#568 - 3g-dialer doesn't ask for user, password, apn. Expand Collapse

3g-dialer does not ask for user and password. Also, apn is ignored too. The apn of Ancel Uruguay in the template is wrong (it is wrong in other distros of Linux too), must be "adslmovil" not "gprs". So, the dialer does not connect to the Internet with 3g modems. Tested witha a Huawei e226.


FS#573 - autolaunchers: disable when needed (gparted) Expand Collapse

Before to run the mount function, check if gparted/fdisk/cfdisk/* is running in order to avoid problems


FS#576 - net-connector: Stop to SCAN networks if we are connected Expand Collapse

If we are already connected to internet is useless to scan about networks, disable the scan until we are disconnected (the non-stop scanning thing makes that some wireless drivers blocks and a reboot is required to recover the connection)


FS#596 - smb-usershare some warning messages Expand Collapse

some error messages when you run smb-usershare are shown in the terminal, but not graphically, this can be a problem when the user is running the application from graphical mode only (menu applications launchers).

In my case, just repackaging it for the new version i found these messages:

Lacking to install the "samba" package:

net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No existe el fichero o el directorio
Please ask your system administrator to enable user sharing.
Traceback (most recent call last):
  File "/usr/bin/smb-usershare", line 580, in <module>
    gui.msgbox(START_MSG)
TypeError: msgbox() takes exactly 3 arguments (2 given)

Lacking to add the user to "samba" (sudo adduser me sambashare), i comment the exact parameter because maybe is a good idea to request the root password via "gksu" tool to do it for the user

net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Permiso denegado
You do not have permission to create a usershare. Ask your administrator to grant you permissions to create a share.
Traceback (most recent call last):
  File "/usr/bin/smb-usershare", line 580, in <module>
    gui.msgbox(START_MSG)
TypeError: msgbox() takes exactly 3 arguments (2 given)

FS#597 - smb-browser requires smbfs which is not available right now Expand Collapse

smbmount is required for smb-browser, but the package smbfs is not available in debian wheezy right now, i'm not sure why, maybe is replaced by the package cifs-utils, or maybe it enters back in the future (release of wheezy stable), in any of the cases i leave this report opened to know that something needs to be fixed around :), which means adapt smb-browser to the new tool or get some kind of port

PS: in any of the cases, smb-browser is not a strict requirement for Elive since thunar is able now to browse samba networks in a friendly way


FS#598 - smb-admin breaks smb.conf Expand Collapse

after to create a user in samba (previously on my system), i can't share folders anymore", and this message:

$ smb-usershare -p princeamd/                           % 
net usershare: usershares are currently disabled
 Traceback (most recent call last):
 File "/usr/bin/smb-usershare", line 580, in <module>
  gui.msgbox(START_MSG)
 TypeError: msgbox() takes exactly 3 arguments (2 given)

FS#599 - Flash for chromium Expand Collapse

Chromium complains about outdated flash version, like in www.electroswing-radio.com , there's some bugs reported in debian (bts show chromium), so we need to wait the release of debian first to see what happens with this


FS#600 - sound card problem with intel models 3400 Expand Collapse

This workaround in needed for these models 3400

root $ echo "options snd_hda_intel model=auto" » /etc/modprobe.d/alsa-base.conf ; rmmod snd_hda_intel ; modprobe snd_hda_intel


FS#601 - VLC ugly subtitles Expand Collapse

By default if you play a DVD and enable subtitles in VLC, they looks ugly as 2 hells, I think that this can be solved in the settings (advanced/all?), we need to play / beta-test a bit to see a solution for that


FS#606 - black screen (console) in boot of live Expand Collapse

PrinceAMD has a computer which when kms loads, the console turns blank, user can't see anything, but the system continue booting correctly (1-2 minutes in blank)

Maybe should be good to add a boot option in the live menu with this entry: nomodeset that solves the problem, for those cases


FS#607 - e17 Menus Freezes after Wizard (not solved) Expand Collapse

Lastest e17, after to finish wizard go fast to the applications menu and scroll it, e17 freezes

This bug reported by AlexAnteMachina has nothing to do with composite, not even with vbox, I tried it in laptop and e17 simply gets frozen, seems like X11 is died, very strange bug! even with my libs updated without the optimize options (please somebody confirm that we have debug messages now), there's simply no way to get a backtrace because everything is blocked (well, you can kill X11, but you lose everything)

Maybe there's not even needed to select German language, it looks like an efreet bug


This is another bug, but seems like caused by the same reason, sometimes, and just sometimes, e17 starts looking like this (some hang in the startup of efreet, or uncomplete or similar, idk)
http://main.elivecd.org/tmp/enlightenment/shot-2013-06-01_22-24-45.jpg

A restart of e17 will solve the problem, but is not a good way to start e17 of course


Another bug: if you install eltrans (here is elive in version 2.1.40), and you try to open the menus, it becomes frozen


FS#612 - Upgrade mode bugs Expand Collapse

Multiple reports:

- If you run the upgrade mode with the beta version, it doesnt seems to boot it (file not found)

- The entry from grub is not removed after the first (any state) reboot

- The installer of 3.0 needs to be adapted


FS#613 - xrandr / e17 screens after play a game isn't restored Expand Collapse

xrandr / e17 screen confs are not restored after to have played a game or launched some applications that changes the screen sizes

Try for example with "smc" (super mario chronicles) package in debian

WARNING: "cd .e ; bkp s", it will broke your e17 conf

Note: maybe only in xinerama ?


FS#614 - Menu in desktop must be in left button Expand Collapse

Users are used of the left-click in desktop (or in a Start button), but not the right now which is the one is actually assigned the e17 menu popup

This must be changed, since we don't use the "favorites" anymore in e17

Thanks Tio for this report


Roadmap for version 3.x (dev before 4.0)

0% of 0 tasks completed.

Roadmap for version 4.0

0% of 0 tasks completed.

Roadmap for version 5.0

0% of 0 tasks completed.

Text Version