Elive Bug Tracking System Elive Bug Tracking SystemElive: Recently closed tasks http://bugs.elivecd.org/ 2017-10-26T15:06:26Z FS#660: Black screen 2017-10-26T15:06:26Z 2017-10-08T09:04:29Z

Hi,

I have yesterday finished installation of last beta version. Unfortunately I wasn’t front of my laptop when the installation process went to an end. I think that there’s probably on last step something like how to boot the system isn’t it? Now the system doesn’t boot and I can’t access bios... Have you some idea what to now? I’ m using Lenovo ThinkPad E530c.
Thanks.

BR,

Vlad.

Vlado Poleva http://bugs.elivecd.org/:660
FS#639: mixer module not present in e17-stable 2017-08-28T00:00:28Z 2014-10-23T21:40:48Z

I don’t see the mixer module in e17-stable

jlslegalize http://bugs.elivecd.org/:639
FS#616: Removing packages could lead to errors 2017-08-27T23:23:45Z 2014-06-18T16:15:27Z

Users should not remove essential packages, but they do...

We will need some kind of feature that at shutdown (more reliable than boot-time) will check if we have removed any essential-elive package and asks if restore it

Thanatermesis http://bugs.elivecd.org/:616
FS#631: Audio card configurator happens twice 2017-08-27T23:23:30Z 2014-08-09T14:16:26Z

In my thinkpad laptop, if i run wizard (new .e) i got the audio configurator that asks me twice, see if this happens after to upgrade to 3.0-rc

Thanatermesis http://bugs.elivecd.org/:631
FS#640: E segfaults when pressing power button + keyboard keys 2017-08-27T23:23:19Z 2014-11-27T19:04:06Z

If you press the power button (which shows a menu option in E to close computer) and extremely-fastly you press any keyboard key, you got a segfault

This can help making it to appear: cd /tmp ; mprime-cpu -t
Also if you add a “drop caches” on that command should help too, giving you more human-time over computer-time

<PrinceAMD> what i think is happening here is
<PrinceAMD> an object is deleted, then a key pressed on the object causes seff
<PrinceAMD> so i think some check is needed in _e_manager_cb_key_down
<PrinceAMD> i'm guessing this is a keybinding bug, so lets say the binding trigger a call of a deleted pointer,
Thread 1 (Thread 0xb5c619a0 (LWP 7261)):
#0  0xb7270607 in pause () at ../sysdeps/unix/syscall-template.S:82
No locals.
#1  0x0807ba9e in e_alert_show () at e_alert.c:38
No locals.
#2  0x08160903 in e_sigseg_act (x=11, info=0xbfe18b8c, data=0xbfe18c0c) at e_signals.c:71
No locals.
#3  <signal handler called>
No symbol table info available.
#4  0x00000020 in ?? ()
No symbol table info available.
#5  0x081479d9 in e_object_del (obj=0x9964768) at e_object.c:54
No locals.
#6  0x080808cf in _e_actions_act_halt_go (obj=0x9678cd8, params=0x0) at e_actions.c:2265
No locals.
#7  0x08089591 in e_bindings_key_down_event_handle (ctxt=E_BINDING_CONTEXT_MANAGER, obj=0x9678cd8, ev=0x996d9e8) at e_bindings.c:514
        act = 0x9894d78
        mod = E_BINDING_MODIFIER_NONE
        binding = 0x98cac98
        l = 0x98c9c80
#8  0x0813764c in _e_manager_cb_key_down (data=0x9678cd8, ev_type=50, ev=0x996d9e8) at e_manager.c:758
        man = 0x9678cd8
        e = 0x996d9e8
#9  0xb6f95c2f in _ecore_call_handler_cb (func=0x81375e8 <_e_manager_cb_key_down>, data=0x9678cd8, type=50, event=0x996d9e8) at lib/ecore/ecore_private.h:359
        r = 1 '\001'
#10 0xb6f96b6a in _ecore_event_call () at lib/ecore/ecore_events.c:562
        ret = 1 '\001'
        e = 0x9a8ca58
        handle_count = 2
        l = 0x0
        l_next = 0x0
        eh = 0x95e1df0
#11 0xb6fa1167 in _ecore_main_loop_iterate_internal (once_only=0) at lib/ecore/ecore_main.c:1942
        next_time = 0.24938403899795958
#12 0xb6f9f419 in ecore_main_loop_begin () at lib/ecore/ecore_main.c:983
No locals.
#13 0x08078164 in main (argc=1, argv=0xbfe1a284) at e_main.c:1138
        nostartup = 0 '\000'
        safe_mode = 0 '\000'
        after_restart = 1 '\001'
        waslocked = 0 '\000'
        t = 1417114627.236887
        tstart = 1417114627.236887
        s = 0x0
        buff = "1417114627.2\000\277{\267@\304z\267\001\000\000\000\000\020e\266\240\221", <incomplete sequence \341\277>
        action = {__sigaction_handler = {sa_handler = 0x8160988 <e_sigabrt_act>, sa_sigaction = 0x8160988 <e_sigabrt_act>}, sa_mask = {__val = {0 <repeats 32 times>}}, sa_flags = -1073741820, sa_restorer = 0xbfe18fd0}
        __FUNCTION__ = "main"
Thanatermesis http://bugs.elivecd.org/:640
FS#643: Most of .desktop doesn't respect XDG_DATA_DIRS 2017-08-27T23:21:50Z 2014-12-26T00:59:23Z

XDG_DATA_DIRS defines the order to where to search for .desktop files, for example we have apulse-skype package that replaces a .desktop that is defined on a previous dir on this variable, this perfectly works if you run skype from menus (skype that requires pulseaudio using a pulseaudio emulator work in alsa-only), but if you run it from engage or from ibar, it doesn’t works (so looks like it gots the .desktop from the default dir instead of the one that we have defined), it doesnt works also from other places like “startup applications”

Thanatermesis http://bugs.elivecd.org/:643
FS#645: E resolution is fucked sometimes 2017-08-27T23:21:21Z 2015-01-15T18:48:31Z

If you run something like “berusky” (small game, which don’t works in fact), it fucks your X resolution without possibility to recover it (BIG BAD BUG)

In short it seems like to: change your E resolution, don’t restore the original one, but E saves and remebers it

We should need a way to detect that the resolution was changed by FOO, when FOO finishes and some seconds passed change the resolution to the original one if we are not on it (not sure if this is possible)

Also, is needed to save the resolution on E confs only when we select to save it, seems like there’s a trigger that saves it automatically, this is very bad :P

Notes: betatest in e19 to see if the bug is solved (and so just cherry-pick the fixes)

Thanatermesis http://bugs.elivecd.org/:645
FS#642: E17 segfault when browsing the menu 2017-08-27T21:32:10Z 2014-12-26T00:27:40Z

After to have opened the menu it frozen and then segfaulted, computer is a nettop, seems like nettops are much more prone to segfault since they are slower :)

Thanatermesis http://bugs.elivecd.org/:642
FS#641: EXT4 mount problems in last versions 2017-08-27T21:31:02Z 2014-12-17T14:56:35Z

I received these messages on IRC thanks to elmo40, but it doesn’t happens to me as you can see on this screenshot:

https://www.enlightenment.org/ss/e-549198d97b8fe3.16604264.jpg

Still having the problem ? How I can reproduce it ?

<elmo40> Thanatermesis: did you get the message ?
<elmo40> AlexAnt couldn't read his existing ext4 partition while trying the latest live image.
<elmo40> (2:37:54 PM) AlexAnteMachina: ext4 is an unknown filesystem to elive??? really???
<elmo40> (2:51:41 PM) AlexAnteMachina: thunar rejects to access my hdd
<Thanatermesis> elmo40, thx, ill check that
Thanatermesis http://bugs.elivecd.org/:641
FS#613: xrandr / e17 screens after play a game isn't restored 2017-08-27T21:25:34Z 2014-04-10T12:17:08Z

xrandr / e17 screen confs are not restored after to have played a game or launched some applications that changes the screen sizes

Try for example with “smc” (super mario chronicles) package in debian

WARNING: “cd .e ; bkp s”, it will broke your e17 conf

Note: maybe only in xinerama ?

Thanatermesis http://bugs.elivecd.org/:613