Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /home/elivebugs/bugs.elivecd.org/includes/class.tpl.php on line 552 FS#231 : Wrong keyboard layout in xorg.conf when changing to "estonian" in elpanel

Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Installed Mode
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Normal
  • Reported Version 1.x Gem+ (developmen
  • Due in Version Undecided
  • Due Date Undecided
Attached to Project: Elive
Opened by meborc (meborc) - 2008-09-14
Last edited by Thanatermesis (thanatermesis) - 2009-03-29

FS#231 - Wrong keyboard layout in xorg.conf when changing to "estonian" in elpanel

system: elive 1.8.8 (downloaded from elivecd.org) installed on inspiron 1520

the default language is us and it is OK... the problem is when i change the keyboard layout to estonian in elpanel, the output of the keys is totally mangled. it looks something like a mix between webdings and chinese

since the layout is NOT giving latin letters, the user is unable to log in. this is a big problem for those new users trying out linux/elive... they have no idea how to fix xorg.conf themselves.

logging in from command line i was able to see that the xorg.conf had “et” as a layout instead of “ee”

after changing the layout to “ee” manually, everything works again


This task does not depend on any other tasks.

Closed by  Thanatermesis (thanatermesis)
Sunday, 29 March 2009, 16:25 GMT
Reason for closing:  Fixed
meborc (meborc)
Sunday, 26 October 2008, 13:16 GMT
Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /home/elivebugs/bugs.elivecd.org/includes/class.tpl.php on line 552

the same bug is in 1.9.10 development version of elive...

it should be an easy fix... please correct it :)

meborc (meborc)
Tuesday, 24 March 2009, 18:43 GMT
Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /home/elivebugs/bugs.elivecd.org/includes/class.tpl.php on line 552

The same bug is in 1.9.23

no estonian will take elive seriously with this bug in :)

Thanatermesis (thanatermesis)
Sunday, 29 March 2009, 16:25 GMT
Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method dokuwiki_TextFormatter::render() should not be called statically in /home/elivebugs/bugs.elivecd.org/includes/class.tpl.php on line 552

This is a perfect bug report, clear, saying what fails and to what needs to be changed, fixed in less than 10 seconds :)

Loading...