Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Any
  • Assigned To
    Thanatermesis
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 2.x (dev before 3.0)
  • Due in Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Elive
Opened by Thanatermesis - 2014-08-28
Last edited by Thanatermesis - 2014-08-28

FS#634 - Chromium problem with moving tabs

I’ve noticed something with the tabs and windows in chromium that u might find interesting :)
Chromium ‘bugs’ with handling from one instance tab → window → another instance tab http://mwow.dk/data/action/vid/this-1-1.ogv

This bug happens since some update of chromium in debian wheezy, 35.0.1916.153-1~deb7u1, it works with the previous version 34.0.1847.116-1~deb7u1

Closed by  Thanatermesis
28.08.2014 15:07
Reason for closing:  Fixed
Admin
Thanatermesis commented on 28.08.2014 09:32

thanks for point me out this issue, i have see it in the past and totally forget because it doesn't happened to me again (so i forced the hold of an older package because another issue with using own .Xmodmap), i think that I should include an older version in elive for solve this

Admin
Thanatermesis commented on 28.08.2014 09:33

the strange thing is that it is not reported to debian, which is where the problem comes from (the updated version of chromium in debian, included in debian stable), which leads me... it only happens on enlightenment ?

Can you verify if this issue only happens on enlightenment and not other window-managers ? for example, try to install fluxbox or any other light one, log on this window-manager and see if the issue is around, that is important to know

Jonas Kervin Hansen commented on 28.08.2014 10:34

Confirmed Enlightenment only using XFCE4.

http://mwow.dk/data/action/vid/this-1-3.ogv

Admin
Thanatermesis commented on 28.08.2014 11:46
I just confirmed it is indeed a Enlightement only issue (perhaps composite?)
Admin
Thanatermesis commented on 28.08.2014 11:47

Hum.. it bugs if you disable composite ? (you can do it from the e17 preferences menus, in looknfeel → composite i think

Admin
Thanatermesis commented on 28.08.2014 11:55

See this small convo, seems like i really need to downgrade chromium :)

<Thanatermesis> can anybody confirm me that there's a bug in Chromium with tabs ? (only with Enlightenment!), i want to know if the problem is only e17 or it happens too in bigger versions
<Thanatermesis> how to reproduce:  drag a chromium tab "out of chromium" (will appear in new window), then drag it again back to the main chromium window, you can't do it easly so it looks like resets its position
<raster> i can bet you i know what the bug likely is
<raster> and its chromium
<bu5hm4n> Thanatermesis: I am on master, works here :)
<bu5hm4n> but something breaks when I am doing that :D
<bu5hm4n> lolol
<raster> i think it might be using the input only window we use for direction input to either evas compositor canvas or to clients
<Thanatermesis> btw, the bug doesntt happens in older versions of chromium, more exactly in debian stable/wheezy:
<raster> as that covers the screen
<Thanatermesis>   Instalados: 34.0.1847.116-1~deb7u1
<Thanatermesis>   Candidato:  35.0.1916.153-1~deb7u1
<raster> but we use shape extn to cut holes out of it for windows
<raster> yeah
<Thanatermesis> second one bugs, which is an update of chromium in debian stable (heh! stable!)
<raster> crhomium dropped gtk
<raster> and did their own display system abstraction
<raster> ocne they did that a tonne of stuff broke
<raster> as they just dont handle a lot of cases
<raster> it really is a chromum problem
<Thanatermesis> ooh
<bu5hm4n> https://www.enlightenment.org/ss/display.php?image=e-53ff179ced33b4.63240460.jpg
<Thanatermesis> and thats also why my Xmodmap is totally fcked with the new chromium too :)
<bu5hm4n> I never saw something like this before :D
<Thanatermesis> damn them

@princeamd you may found this interesting topic ^

Jonas Kervin Hansen commented on 28.08.2014 12:12

I can confirm it is to do with OpenGL rendering in Composite.

sorry for the late reply, i had to burst on some work for a project due to a sudden request for additional features.

Admin
Thanatermesis commented on 28.08.2014 13:48

open a terminal and run "apug", it should downgrade chromium version, tell me if this fixes the problem :)

Jonas Kervin Hansen commented on 28.08.2014 14:31

It has solved the window↔tab problem to downgrade which indicates it is chromiums display system that causes problems when openGL Composite rendering is enabled.

Admin
Thanatermesis commented on 28.08.2014 15:06

good :), we are going to use this older version until chromium does a good version without this and another issue (xmodmap, as said in the comments by raster), we need a reliable and working version of the browser!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing