Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Live Mode
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 2.x (dev before 3.0)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Elive
Opened by John Agapito - 2018-01-17
Last edited by Thanatermesis - 2018-02-14

FS#672 - Screen lock ineffective

Running 2.9.22.

Crl-Alt-L is supposed to lock the screen but no password is necessary. Simply hit enter and the screen unlocks.

Running on Dell XPS 13 L322x

Closed by  Thanatermesis
14.02.2018 22:55
Reason for closing:  Fixed
Admin
Thanatermesis commented on 17.01.2018 22:59

I have recently worked on this issue, can you try to upgrade your system (open a terminal and run "apug"), then reboot, and see if the locking works correctly?

Thanks

John Agapito commented on 02.02.2018 20:50

Tried that, just now. No change.

Admin
Thanatermesis commented on 03.02.2018 11:31

Hum,

Let me know more details, are you using Ecomorph (special effects) ? if not, which composite mode are you using (software/gl)? is your graphic card intel or which one?

Thanks

John Agapito commented on 04.02.2018 04:02

See below for graphics card info. I tried turning ecomorph on for the first time (I do not want them, but you suggested it...). When it is on, the screen lock works OK - but there is a spinning 3D cube rendering effect that starts after I log in and I cannot find how to turn it off. So - it seems somehow connected to ecomorph. I have openGL on. But I have tried it with software instead, and it seems not to make a difference.

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])

      Subsystem: Dell Device [1028:058b]
      Flags: bus master, fast devsel, latency 0, IRQ 41
      Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
      Memory at c0000000 (64-bit, prefetchable) [size=256M]
      I/O ports at 2000 [size=64]
      Expansion ROM at <unassigned> [disabled]
      Capabilities: <access denied>
      Kernel driver in use: i915
John Agapito commented on 14.02.2018 22:53

elive/e17 updates today seemed to have fixed this. By design? Anyway - all good now.

Admin
Thanatermesis commented on 14.02.2018 22:54

I forgot to answer yesterday, yes it is fixed :), thanks for the report!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing