Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Installed Mode
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version 2.x (dev before 3.0)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Elive
Opened by SykkNyzz - 2018-06-11
Last edited by Thanatermesis - 2018-06-12

FS#694 - Elive freezes at: Loading initial ramdisk after booting.

I previously did the full install of Elive 2.9.9.5 via USB on a Macbook Mid 2009. And things were running smoothly. Afterwards, the grub would appear then it will freeze at Loading initial ramdisk.

Closed by  Thanatermesis
12.06.2018 22:14
Reason for closing:  Fixed
SykkNyzz commented on 11.06.2018 11:43

setparams 'Elive GNU/Linux, with Linux 3.16.0-0.bpo.4686-pae

load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod reiserfs
set root='(hd0,msdos2)'
search –no-floppy –set=root 085deb13-c04a-45af-8bed-07c640f44ab1
echo 'Loading Linux 3.16.0-0.bpo.4686-pae ...'
Linux /boot/vmlinuz 3.16.0-0.bpo.4686-pae root=UUID=085deb13-c04a-45af-8bed-07c640f44ab1 to quiet splash resume=/dev/sda1
echo 'Loading initial ramdisk ...'
united /boot/initrd.img-3.16.0-0.bpo.4686-pae

Admin
Thanatermesis commented on 11.06.2018 11:58

Thanks for report the problem, did you have needed to use any special boot options for the Live mode? which graphic card you use?

SykkNyzz commented on 11.06.2018 12:47

I didn't use any special boot options and I picked Current Nvidia

Admin
Thanatermesis commented on 11.06.2018 14:19

Try to add these boot parameters to see which one is the one that you need:

intremap=off acpi_osi=! acpi_osi=Darwin nomodeset vt.handoff=7
vga=788
vga=791
modprobe.blacklist=nouveau

(try a single line per every boot attempt), removing the "splash" word may also help

can you also run this command and show me the given link?

lshal | elivepaste
Admin
Thanatermesis commented on 11.06.2018 14:26

Also this link seems like to have a kind of fix for the graphic card (see points 2 and 3) https://askubuntu.com/questions/264247/proprietary-nvidia-drivers-with-efi-on-mac-to-prevent-overheating/613573#613573

try these if the previous boot parameters doesn't works

SykkNyzz commented on 11.06.2018 15:52

Thank you. Removing 'splash' was the culprit

Admin
Thanatermesis commented on 11.06.2018 16:32

Only splash? mmh, this is interesting... can you pleas give me the result (link) of this command? so I can fix it in the installer for everybody that will have a macbook :)

lshal | elivepaste
Admin
Thanatermesis commented on 12.06.2018 17:39

Im going to do another build of the pre-release of 3.0, can you please show me the output of that command so that I can make it working by default for everybody that has a macbook ? :-) (by removing the "splash" entry as you said)

lshal | elivepaste
SykkNyzz commented on 12.06.2018 20:07

Did as requested... Accidentally 3 times... only because I didn't know how it was sending. So if you see a triplicate of the same paste... It's mine. Also set in grub.cfg to remove 'splash' and machine boots without worry. Thank you for all your help.

Admin
Thanatermesis commented on 12.06.2018 21:27

But i need the link of the paste :), can you give me it? (just run it again and paste here the link)

SykkNyzz commented on 12.06.2018 22:10

https://pastebin.com/jrRNXXc1 Ended up pasting it there.... I couldn't find the link after sending it to Debian's Paste Zone. I made sure it had everything from the readout
Update:
Upon further inspection. The reason why I couldn't get the link from debian's pastezone is because of it exceeding the amount of characters.
Best regards,
SykkNyzz

Admin
Thanatermesis commented on 12.06.2018 22:13

Perfect, installer ready to disable "splash" on these cases :-), if you reinstall / upgrade elive and is not removed just reopen this bug (so i cannot test it here due to lack of machines)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing