Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Installed Mode
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version 2.x (dev before 3.0)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Elive
Opened by John - 2018-06-29
Last edited by Thanatermesis - 2018-07-05

FS#704 - SubMenu is not showed all after clicking by mouse on desktop near right border

Hello
When I click by mouse on desktop near right border (of desktop), menu is showed all, but if I want to show submenu (for example “Applications” it is showed on the right side of menu and it is not showed all, only partially.

Could you fix it? For example show submenu on the left of mainmenu?

Closed by  Thanatermesis
05.07.2018 15:19
Reason for closing:  Fixed
JF Bourdeau commented on 29.06.2018 19:52

I experienced it do, for now I am simply clicking more on the left if I want to see the complete menu or it's submenus.

But if it's easy to make it appear on the left when needed, when we're positioned too close to the right, indeed it would be useful/cool.

Probably more a request to the enlightenment group ?

JF

Admin
Thanatermesis commented on 05.07.2018 10:49

If im not wrong understanding this "issue", you fix it by simply "pushing" the menu by moving your mouse to the screens limit, so when your menu looks cut, move your mouse to the end of the screen limits and the menu will be pushed / moved

JF Bourdeau commented on 05.07.2018 13:41

That reported behavior / Bug (not realy a bug( , it more forces us to not click at the edge of the screen, on the RIGHT, to use the menus.

If we click, more on the left there won't be a problem, we'll see sub-menus we want.

It is by design, Enlightenment is doing that...(not an elive bug) I tried installing it in Ubuntnu 18.04, use the ENLIGHTENMENT desktop and click on the right of the sceeen and same thing, a part of the menu is missing ( out of the screen)..

So we have to adapt to Elightenment limits

Admin
Thanatermesis commented on 05.07.2018 15:19

Alright,

As I said, move your mouse pointer to the limits to the screen and the menu will be "pushed"

I have changed the configuration to have a margin of 50 limits before to expand (before was zero, so touching the screen limits) so that the menu will expand sooner

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing