Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Betatesting
  • Category Live Mode
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Medium
  • Reported Version 2.x (beta's)
  • Due in Version 3.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Elive
Opened by Thanatermesis - 2018-07-01
Last edited by Thanatermesis - 2018-11-23

FS#705 - Multiple screens betatesting

The new multiple screens betatesting is ready to be used, this task will be to better track all that is needed to betatest:

How to use it: Everything should be automated, so just upgrade your system with the command “apug” and restart to a new desktop configuration (from elive menus), which is important too. It should detect that you have multiple screens and ask you to configure them, or use an existing configuration, etc in contrary case you still have the configurator available (only one now, which is an elive tool)

Things to betatest: This is the list:

  1. all the options and behaviours (what if select no, yes, save, not save, remove, etc), this is more or less already betatested by me
  2. try to disconnect the extra screen, reboot computer, your desktop should be equally functional (and I assume not asking/saying anything about)
  3. poweroff again the computer, connect again the extra screen, it should remember that configuration for your second screen and going back to these settings (without asking anything, i assume)
  4. there’s some games that changes your screen resolution (in order to play in fullscreen), if the game exits with an error your desktop is messed up (desktop running in a strange resolution), the normal behaviour is to return to the correct resolution when the game exits correctly, but i dont know if this happens or even if goes to the correct multiscreen mode. Also: a reboot should perfectly return to the normal behaviour
  5. maybe already said before, but switching between “using and not using” the external screen should be not a painful experience (and/or with reboots), it should be “work on the fly”
  6. ecomorph (special effects) should work correctly, except for the “exposé effect” which doesn’t seems to like it so much (confused numbers of desktops, etc, not sure if this one works better after the full implementation)
  7. detail: technically speaking, there’s two launching of the “load screen settings”, one happens before the desktop is loaded and the other when the desktop has started to load... in other words: if there’s a widget/question that asks for anything it should always happen when you already have access to the window controls (including window borders for example)
  8. since i found a strange behavior with the “automated fonts sizing calculation” feature, i include this betatest point: test if the font sizes are not reconfigured “smaller than normal”
  9. we have hotkeys to switch between virtual desktops, do we have a setup for between screens? i just tried to configure a new keyboard hotkey (ctrl + alt + shift + arrows) for switch to another screen 0/1 but doesn’t looks like to work on virtualbox... will need to do test in a real machine (and implement the hotkey in the default configuration)

Notes: if any of these betatests are not working as expected, please include the details of the “steps” about how to reproduce it, and the exact (first words) of the “conflicting” message found

Closed by  Thanatermesis
23.11.2018 02:16
Reason for closing:  Implemented
Admin
Thanatermesis commented on 01.07.2018 01:19

Note: already betatested with 2-screens hardware and a 4 screens virtualbox setup, it should work with up to 10 preconfigured desktops (do we need to preconfigure more than 10?)

JF Bourdeau commented on 05.07.2018 12:29

Screen configuration work better for mew now, it is not clear for me how to choose which screen i the default one... Some box popup window asked me once which one I wannted, by mistake i did something and it dissapeared and I didn't know how to get back that windows to choose the default monitor.

JF

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing