Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Live Mode
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 2.x (dev before 3.0)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Elive
Opened by JF Bourdeau - 2018-08-04
Last edited by Thanatermesis - 2018-08-04

FS#712 - My 2 screen are black

I booted today and I can only see the mouse on my 2 screen.

I can go into console mode to reboot, but at reboot, same scenario. 2 BLack screen, only see the mouse

Weird that it happen suddenly, I had to reboot in Elive yesterday 2 or 3 times without having that problem.

What are your recommendations to avoid reinstalling ?

Cause: ecomorph
TODO: do not allow ecomorph at emodule level (loading module)

JF

Closed by  Thanatermesis
04.08.2018 23:08
Reason for closing:  Fixed
Admin
Thanatermesis commented on 04.08.2018 16:39

I don't think that reinstalling could solve the problem, sounds like the desktop is broken somewhat

What is your actual settings for Ecomorph and for composite? (composite enabled? in software or GL mode?, and ecomorph is enabled?)

See that is not needed to restart the desktop configurations to change these settings (is just a fast way to do it)

JF Bourdeau commented on 04.08.2018 16:42

I don't remember if ecomorph was on, Open GL mode is on
From the console / command line, what could I type ?

Tks !
I think, yesterday before shutting down, I turned on Ecomorph...

Admin
Thanatermesis commented on 04.08.2018 16:52

* ecomorph only works on GL mode
* composite can run in GL or Software mode

This sounds like a GL issue, so just disable everything on GL (disable ecomorph and use composite in software mode)

From the console / command line, what could I type ?

e17-restart-<TAB> if you want to restart to a new desktop configuration (if your desktop is not reachable)

I think, yesterday before shutting down, I turned on Ecomorph...

This is a problem... i mean, talking about usability, I tried to make clear messages saying that ecomorph it can be not stable (but it can be, depending of the hardware) so that the user will understand that if has any issues, is not a bug in elive, is because of the drivers conflicting with GL stuff for being using ecomorph or gl...

In other words, since Elive meant to be a stable system, it should ecomorph entirely removed in order to avoid these issues?

JF Bourdeau commented on 04.08.2018 17:19

I tried several times

e17-restart-<TAB> if you want to restart to a new desktop configuration (if your desktop is not reachable)

Everytime it is bringing me ot the login screen, I enter my password and end up with blanks screens

Is there something else I could do to reset ?

JF

As for :
In other words, since Elive meant to be a stable system, it should ecomorph entirely removed in order to avoid these issues?

I choose to turned ecomorph on to see how it would go. and it went not so bad, animations were ok etc. but it's after the restart I had problem.

You have 3 choices

1- No ecomorph at all
2- Only allow ecomorph if one screen ? I don't know if you can do that, borbid people to activate it on 2 screen

Ecomorph is cool but i think it could cause problems.... I mean to let people " be able " to activate it on 2 screens....

Admin
Thanatermesis commented on 04.08.2018 17:40
Everytime it is bringing me ot the login screen, I enter my password and end up with blanks screens

You mean the configurator of languages? that's strange because GL is not loaded on this step until the checkbox (so it should be disabled for your case)

I choose to turned ecomorph on to see how it would go. and it went not so bad, animations were ok etc. but it's after the restart I had problem.

So not use ecomorph if doesn't works correctly in your hardware, mmmh... I should probably improve the messages in ecomorph

2- Only allow ecomorph if one screen ? I don't know if you can do that, borbid people to activate it on 2 screen

what? im confused now... I recently updated multiscreens to automatically disable ecomorph if ecomorph was used, ecomorph doesn't works with multiscreens. It does not automatically disable it?

JF Bourdeau commented on 04.08.2018 17:44

- Ecomorph is disabled with multi screen...BUT, we can turn it back on.

- Everytime it is bringing me ot the login screen, I enter my password and end up with blanks screens You mean the configurator of languages? that's strange because GL is not loaded on this step until the checkbox (so it should be disabled for your case)

I boot
I don't see anything
Ctrl + Atl F1
I log
I send your command e17 etc....
Login ( user / password) sceeen show up
I log
Still back screens

JF Bourdeau commented on 04.08.2018 20:59

Hurray !
I was able to unclick the OPEN GL / Hardware accelerated mode in a smal sma small window (size of the mouse).

and now my dekstop is back !

Admin
Thanatermesis commented on 04.08.2018 21:34
- Ecomorph is disabled with multi screen...BUT, we can turn it back on.

Ok, I improved the launcher of ecomorph to tell and not load it when multiscreens (can be still loaded manually as a module but at least is an improvement)

Well, if you start a new desktop configuration and you don't use ecomorph with multiscreens you should not have problems, I dont think that you can have problems with composite in GL mode (but ecomorph should be the broken one)

JF Bourdeau commented on 04.08.2018 22:03

For now I am ok, GL or not GL, I am able to make my 2 screens works
tks

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing