Elive

Help us in a better way with reports that includes all the needed (but not excesive) information and how to reproduce it. It may not mean a lot to you, but it means a world to us.

ID  descOpenedLast EditedTask TypeSummaryStatusOpened byProgressDue In Version
 660 2017-10-082017-10-26Bug Report Black screen  ClosedVlado Poleva
100%
3.0 Task Description

Hi,

I have yesterday finished installation of last beta version. Unfortunately I wasn’t front of my laptop when the installation process went to an end. I think that there’s probably on last step something like how to boot the system isn’t it? Now the system doesn’t boot and I can’t access bios... Have you some idea what to now? I’ m using Lenovo ThinkPad E530c.
Thanks.

BR,

Vlad.

 659 2017-08-262017-08-26Feature Request Backbutton in install ClosedGrottem
100%
3.0 Task Description

a back button is needed in during the installation progress

 657 2017-06-202017-08-27Bug Report Not Booting - dm_raid45 not found Closedmartin prior
100%
3.0 Task Description

PLEASE be describable, clear, and direct. Think that we need to understand, found, and solve the bug.

Remember to set the Due in Version box into the next stable version number.

Thank you

elive 2.9.2 USB I have tried this in a Pentium system and cannot fully boot an hangs with message: module dm_raid45 not found in modules.dep

I have also tried booting an Acer 5532. Same problem

 645 2015-01-152017-08-27Bug Report E resolution is fucked sometimes ClosedThanatermesis
100%
3.0 Task Description

If you run something like “berusky” (small game, which don’t works in fact), it fucks your X resolution without possibility to recover it (BIG BAD BUG)

In short it seems like to: change your E resolution, don’t restore the original one, but E saves and remebers it

We should need a way to detect that the resolution was changed by FOO, when FOO finishes and some seconds passed change the resolution to the original one if we are not on it (not sure if this is possible)

Also, is needed to save the resolution on E confs only when we select to save it, seems like there’s a trigger that saves it automatically, this is very bad :P

Notes: betatest in e19 to see if the bug is solved (and so just cherry-pick the fixes)

 643 2014-12-262017-08-27Bug Report Most of .desktop doesn't respect XDG_DATA_DIRS ClosedThanatermesis
100%
3.0 Task Description

XDG_DATA_DIRS defines the order to where to search for .desktop files, for example we have apulse-skype package that replaces a .desktop that is defined on a previous dir on this variable, this perfectly works if you run skype from menus (skype that requires pulseaudio using a pulseaudio emulator work in alsa-only), but if you run it from engage or from ibar, it doesn’t works (so looks like it gots the .desktop from the default dir instead of the one that we have defined), it doesnt works also from other places like “startup applications”

 642 2014-12-262017-08-27Bug Report E17 segfault when browsing the menu ClosedThanatermesis
100%
3.0 Task Description

After to have opened the menu it frozen and then segfaulted, computer is a nettop, seems like nettops are much more prone to segfault since they are slower :)

 641 2014-12-172017-08-27Bug Report EXT4 mount problems in last versions ClosedThanatermesis
100%
3.0 Task Description

I received these messages on IRC thanks to elmo40, but it doesn’t happens to me as you can see on this screenshot:

https://www.enlightenment.org/ss/e-549198d97b8fe3.16604264.jpg

Still having the problem ? How I can reproduce it ?

<elmo40> Thanatermesis: did you get the message ?
<elmo40> AlexAnt couldn't read his existing ext4 partition while trying the latest live image.
<elmo40> (2:37:54 PM) AlexAnteMachina: ext4 is an unknown filesystem to elive??? really???
<elmo40> (2:51:41 PM) AlexAnteMachina: thunar rejects to access my hdd
<Thanatermesis> elmo40, thx, ill check that
 640 2014-11-272017-08-27Bug Report E segfaults when pressing power button + keyboard keys ClosedThanatermesis
100%
3.0 Task Description

If you press the power button (which shows a menu option in E to close computer) and extremely-fastly you press any keyboard key, you got a segfault

This can help making it to appear: cd /tmp ; mprime-cpu -t
Also if you add a “drop caches” on that command should help too, giving you more human-time over computer-time

<PrinceAMD> what i think is happening here is
<PrinceAMD> an object is deleted, then a key pressed on the object causes seff
<PrinceAMD> so i think some check is needed in _e_manager_cb_key_down
<PrinceAMD> i'm guessing this is a keybinding bug, so lets say the binding trigger a call of a deleted pointer,
Thread 1 (Thread 0xb5c619a0 (LWP 7261)):
#0  0xb7270607 in pause () at ../sysdeps/unix/syscall-template.S:82
No locals.
#1  0x0807ba9e in e_alert_show () at e_alert.c:38
No locals.
#2  0x08160903 in e_sigseg_act (x=11, info=0xbfe18b8c, data=0xbfe18c0c) at e_signals.c:71
No locals.
#3  <signal handler called>
No symbol table info available.
#4  0x00000020 in ?? ()
No symbol table info available.
#5  0x081479d9 in e_object_del (obj=0x9964768) at e_object.c:54
No locals.
#6  0x080808cf in _e_actions_act_halt_go (obj=0x9678cd8, params=0x0) at e_actions.c:2265
No locals.
#7  0x08089591 in e_bindings_key_down_event_handle (ctxt=E_BINDING_CONTEXT_MANAGER, obj=0x9678cd8, ev=0x996d9e8) at e_bindings.c:514
        act = 0x9894d78
        mod = E_BINDING_MODIFIER_NONE
        binding = 0x98cac98
        l = 0x98c9c80
#8  0x0813764c in _e_manager_cb_key_down (data=0x9678cd8, ev_type=50, ev=0x996d9e8) at e_manager.c:758
        man = 0x9678cd8
        e = 0x996d9e8
#9  0xb6f95c2f in _ecore_call_handler_cb (func=0x81375e8 <_e_manager_cb_key_down>, data=0x9678cd8, type=50, event=0x996d9e8) at lib/ecore/ecore_private.h:359
        r = 1 '\001'
#10 0xb6f96b6a in _ecore_event_call () at lib/ecore/ecore_events.c:562
        ret = 1 '\001'
        e = 0x9a8ca58
        handle_count = 2
        l = 0x0
        l_next = 0x0
        eh = 0x95e1df0
#11 0xb6fa1167 in _ecore_main_loop_iterate_internal (once_only=0) at lib/ecore/ecore_main.c:1942
        next_time = 0.24938403899795958
#12 0xb6f9f419 in ecore_main_loop_begin () at lib/ecore/ecore_main.c:983
No locals.
#13 0x08078164 in main (argc=1, argv=0xbfe1a284) at e_main.c:1138
        nostartup = 0 '\000'
        safe_mode = 0 '\000'
        after_restart = 1 '\001'
        waslocked = 0 '\000'
        t = 1417114627.236887
        tstart = 1417114627.236887
        s = 0x0
        buff = "1417114627.2\000\277{\267@\304z\267\001\000\000\000\000\020e\266\240\221", <incomplete sequence \341\277>
        action = {__sigaction_handler = {sa_handler = 0x8160988 <e_sigabrt_act>, sa_sigaction = 0x8160988 <e_sigabrt_act>}, sa_mask = {__val = {0 <repeats 32 times>}}, sa_flags = -1073741820, sa_restorer = 0xbfe18fd0}
        __FUNCTION__ = "main"
 636 2014-08-302017-08-26Bug Report windows moves to the first screen ClosedThanatermesis
100%
3.0 Task Description

You said recently that you have found the cause of the bug where teh windwos are positioned in the first screen (xinerama) when looking at something else about borders?, but i still having the bug around, did you commited the fix ?

 634 2014-08-282014-08-28Bug Report Chromium problem with moving tabs ClosedThanatermesis
100%
3.0 Task Description
I’ve noticed something with the tabs and windows in chromium that u might find interesting :)
Chromium ‘bugs’ with handling from one instance tab → window → another instance tab http://mwow.dk/data/action/vid/this-1-1.ogv

This bug happens since some update of chromium in debian wheezy, 35.0.1916.153-1~deb7u1, it works with the previous version 34.0.1847.116-1~deb7u1

 633 2014-08-222017-08-27Bug Report urxvt from thunar shows wrong colours ClosedThanatermesis
100%
3.0 Task Description

If you open terminal from thunar, which is assigned to urxvt, the colors theme is not considered, it doesn’t read our .Xdefaults file ?

 632 2014-08-192014-09-26Bug Report Thunar @Folder > right click > create document freeze ClosedJonas Kervin Hansen
100%
3.0 Task Description

OS: Elive Topaz+ (beta)
Arch: 32bit (x86)
update status: Fully up to date as per official elive repos.

how to reproduce:
Open a folder in Thunar, right click, point at create document = window manager freeze (Entrance?)

heres a video for demonstration:
External Link

 631 2014-08-092017-08-27Bug Report Audio card configurator happens twice ClosedThanatermesis
100%
3.0 Task Description

In my thinkpad laptop, if i run wizard (new .e) i got the audio configurator that asks me twice, see if this happens after to upgrade to 3.0-rc

 630 2014-08-052017-08-06Bug Report gimp don't edit raw files ClosedThanatermesis
100%
3.0 Task Description

There’s multiple packages on gimp for edit raw files, we need to know which one to include (betatesting)

 628 2014-08-022017-08-27Bug Report Keyboard language is ignored if /etc/default/keyboard i ...ClosedThanatermesis
100%
3.0 Task Description

Try to reproduce:

- /etc/default/keyboard is set to “es” - configure E to use US instead
- when you restart e17 is set back to ES

Note: use a new elive install, which sets correctly all those things

 627 2014-07-282017-08-26Bug Report Wrong language conf in wizard ClosedThanatermesis
100%
3.0 Task Description

<Elive_user_en_18> when selecting english Canada changes to French Canada

This report seems to reffer to wizard languages selector I assume

English is english, so french canada is wrong (note that canada has french and english, betatest too if the keyboard is correctly set too)

 624 2014-07-042017-08-26Bug Report E17 crash playing with gadgets ClosedThanatermesis
100%
3.0 Task Description

Thenuxnewbie (princeamd’s friend?) reported a crash on e17 “trying to move gadgets from shelf” he said, attached crasdump file

<Thenuxnewbie> im on wifi and i just noticed something, it would allow me to remove the gadget as long as the wifi signal strength isn’t displayed in what i presume is the system tray
<Thenuxnewbie> but as long as it’s showing signal strength bar, trying to remove the gadged crashes e17

So try to remove the wifi widget with the systray active to reproduce the bug

 621 2014-06-262017-08-26Bug Report Kernel 3.14.7 and Vbox 4.3.12 ClosedDeon Thomas
100%
3.0 Task Description

seem vbox is out of date with this really new kernel so the vboxdrv modules segf somewhere in the kernel, I suggest using a kernel that is supported by vbox, this problem is only with vbox.

 620 2014-06-212017-08-25Bug Report Umounting in thunar fails ClosedThanatermesis
100%
3.0 Task Description

Kill tumblerd always before umounting a partition

~ ps aux | grep 30017
1000 1868 0.0 0.0 5188 732 pts/0 SN+ 17:35 0:00 grep 30017
1000 30017 4.5 3.4 517740 68508 ? Sl 17:12 1:02 /usr/lib/i386-linux-gnu/tumbler-1/tumblerd
~

 619 2014-06-212017-08-27Bug Report audio-configurator smartness ClosedThanatermesis
100%
3.0 Task Description

In laptop of sapi, there’s an hdmi entry that is not a real card, in order to preselect it correctly we could list the channels and see if has any valid entry, for example this wrong one has:

~ amixer
Simple mixer control ‘IEC958’,0

Capabilities: pswitch pswitch-joined penum
Playback channels: Mono
Mono: Playback [off]

~

 618 2014-06-202017-08-27Bug Report Suspend doesn't give you shared folders back ClosedThanatermesis
100%
3.0 Task Description

If you put the laptop to suspend, when you put it back you cannot browse shared folders, this happens on my acer-aspire-one laptop in live mode at least

Maybe there’s a post-suspend hook/script that needs to be added for reload sambasomething ?

 616 2014-06-182017-08-27Bug Report Removing packages could lead to errors ClosedThanatermesis
100%
3.0 Task Description

Users should not remove essential packages, but they do...

We will need some kind of feature that at shutdown (more reliable than boot-time) will check if we have removed any essential-elive package and asks if restore it

 614 2014-04-212017-08-25Feature Request Menu in desktop must be in left button ClosedThanatermesis
100%
3.0 Task Description

Users are used of the left-click in desktop (or in a Start button), but not the right now which is the one is actually assigned the e17 menu popup

This must be changed, since we don’t use the “favorites” anymore in e17

Thanks Tio for this report

 613 2014-04-102017-08-27Bug Report xrandr / e17 screens after play a game isn't restored ClosedThanatermesis
100%
3.0 Task Description

xrandr / e17 screen confs are not restored after to have played a game or launched some applications that changes the screen sizes

Try for example with “smc” (super mario chronicles) package in debian

WARNING: “cd .e ; bkp s”, it will broke your e17 conf

Note: maybe only in xinerama ?

 612 2014-03-182017-08-27Bug Report Upgrade mode bugs ClosedThanatermesis
100%
3.0 Task Description

Multiple reports:

- If you run the upgrade mode with the beta version, it doesnt seems to boot it (file not found)

- The entry from grub is not removed after the first (any state) reboot

- The installer of 3.0 needs to be adapted

 609 2013-10-312013-10-31Bug Report Internet doesn't automatically connect to wifi ClosedThanatermesis
100%
3.0 Task Description

Seems like wifi doesn’t automatically connect when i come back from suspension and im in another location (and I enable the wifi power-button later too), i need to open the internet configurator emodule for to start/open the Network-manager applet (note that by default is removed in order to save some resources consumption and memory usage.

The question is... do we need this nm-applet running all the time so that the network will be correctly connected/updated all the time? this sounds for me non-sense since there’s a daemon of NM, the applect should be only for manual selection or configuration of things, otherwise a daemon should works a daemon.

It happens to you too ?

 607 2013-05-312017-08-26Bug Report e17 Menus Freezes after Wizard (not solved) ClosedThanatermesis
100%
3.0 Task Description

Lastest e17, after to finish wizard go fast to the applications menu and scroll it, e17 freezes

This bug reported by AlexAnteMachina has nothing to do with composite, not even with vbox, I tried it in laptop and e17 simply gets frozen, seems like X11 is died, very strange bug! even with my libs updated without the optimize options (please somebody confirm that we have debug messages now), there’s simply no way to get a backtrace because everything is blocked (well, you can kill X11, but you lose everything)

Maybe there’s not even needed to select German language, it looks like an efreet bug


This is another bug, but seems like caused by the same reason, sometimes, and just sometimes, e17 starts looking like this (some hang in the startup of efreet, or uncomplete or similar, idk)
http://main.elivecd.org/tmp/enlightenment/shot-2013-06-01_22-24-45.jpg

A restart of e17 will solve the problem, but is not a good way to start e17 of course


Another bug: if you install eltrans (here is elive in version 2.1.40), and you try to open the menus, it becomes frozen

 606 2013-04-272017-08-27Bug Report black screen (console) in boot of live ClosedThanatermesis
100%
3.0 Task Description

PrinceAMD has a computer which when kms loads, the console turns blank, user can’t see anything, but the system continue booting correctly (1-2 minutes in blank)

Maybe should be good to add a boot option in the live menu with this entry: nomodeset that solves the problem, for those cases

 602 2013-02-272013-03-28Bug Report Google Talk video-conference ClosedThanatermesis
100%
3.0 Task Description

I just tried to use Google Talk for videoconference (calls) but seems to not work, I tried it on chrome and even installed a .deb package provided by google, it complains about that is not correctly installed or something similar, I will need to make future look to it

 601 2013-02-192017-07-01Feature Request VLC ugly subtitles ClosedThanatermesis
100%
3.0 Task Description

By default if you play a DVD and enable subtitles in VLC, they looks ugly as 2 hells, I think that this can be solved in the settings (advanced/all?), we need to play / beta-test a bit to see a solution for that

 600 2013-02-062014-10-31Bug Report sound card problem with intel models 3400 ClosedThanatermesis
100%
3.0 Task Description

This workaround in needed for these models 3400

root $ echo “options snd_hda_intel model=auto” » /etc/modprobe.d/alsa-base.conf ; rmmod snd_hda_intel ; modprobe snd_hda_intel

 599 2013-01-282017-08-27Bug Report Flash for chromium ClosedThanatermesis
100%
3.0 Task Description

Chromium complains about outdated flash version, like in www.electroswing-radio.com , there’s some bugs reported in debian (bts show chromium), so we need to wait the release of debian first to see what happens with this

 598 2013-01-112017-08-27Bug Report smb-admin breaks smb.conf ClosedDeon Thomas
100%
3.0 Task Description

after to create a user in samba (previously on my system), i can’t share folders anymore”, and this message:

$ smb-usershare -p princeamd/                           % 
net usershare: usershares are currently disabled
 Traceback (most recent call last):
 File "/usr/bin/smb-usershare", line 580, in <module>
  gui.msgbox(START_MSG)
 TypeError: msgbox() takes exactly 3 arguments (2 given)
 597 2012-09-082017-08-26Bug Report smb-browser requires smbfs which is not available right ...ClosedThanatermesis
100%
3.0 Task Description

smbmount is required for smb-browser, but the package smbfs is not available in debian wheezy right now, i’m not sure why, maybe is replaced by the package cifs-utils, or maybe it enters back in the future (release of wheezy stable), in any of the cases i leave this report opened to know that something needs to be fixed around :), which means adapt smb-browser to the new tool or get some kind of port

PS: in any of the cases, smb-browser is not a strict requirement for Elive since thunar is able now to browse samba networks in a friendly way

 596 2012-09-072017-08-26Bug Report smb-usershare some warning messages ClosedThanatermesis
100%
3.0 Task Description

some error messages when you run smb-usershare are shown in the terminal, but not graphically, this can be a problem when the user is running the application from graphical mode only (menu applications launchers).

In my case, just repackaging it for the new version i found these messages:

Lacking to install the “samba” package:

net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No existe el fichero o el directorio
Please ask your system administrator to enable user sharing.
Traceback (most recent call last):
  File "/usr/bin/smb-usershare", line 580, in <module>
    gui.msgbox(START_MSG)
TypeError: msgbox() takes exactly 3 arguments (2 given)

Lacking to add the user to “samba” (sudo adduser me sambashare), i comment the exact parameter because maybe is a good idea to request the root password via “gksu” tool to do it for the user

net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Permiso denegado
You do not have permission to create a usershare. Ask your administrator to grant you permissions to create a share.
Traceback (most recent call last):
  File "/usr/bin/smb-usershare", line 580, in <module>
    gui.msgbox(START_MSG)
TypeError: msgbox() takes exactly 3 arguments (2 given)
 586 2010-08-122017-08-27Bug Report Shared Folders: read-write not working Closedanabell
100%
3.0 Task Description

When trying to share folders in the file-manager, it doesn’t allow you to share it as read-write mode, the permissions are correctly set to the folder to be writable by anyone

 576 2010-04-272017-08-27Bug Report net-connector: Stop to SCAN networks if we are connecte ...ClosedThanatermesis
100%
3.01 Task Description

If we are already connected to internet is useless to scan about networks, disable the scan until we are disconnected (the non-stop scanning thing makes that some wireless drivers blocks and a reboot is required to recover the connection)

 573 2010-04-082017-08-25Bug Report autolaunchers: disable when needed (gparted) ClosedThanatermesis
100%
3.0 Task Description

Before to run the mount function, check if gparted/fdisk/cfdisk/* is running in order to avoid problems

 568 2010-03-282017-08-26Bug Report 3g-dialer doesn't ask for user, password, apn. ClosedLorenzo Maceiras
100%
3.0 Task Description

3g-dialer does not ask for user and password. Also, apn is ignored too. The apn of Ancel Uruguay in the template is wrong (it is wrong in other distros of Linux too), must be “adslmovil” not “gprs”. So, the dialer does not connect to the Internet with 3g modems. Tested witha a Huawei e226.

 567 2010-03-262017-08-25Feature Request printer applet autorun ClosedThanatermesis
100%
3.0 Task Description

When the printer is plugged, run the printer applet and when is unplugged, remove it

 563 2010-03-212017-08-25Bug Report vpn ad-hoc ClosedSpirit
100%
3.0 Task Description

No funciona la conexión punto a punto
Thank you

 562 2010-03-202010-03-20Bug Report autolaunchers with spaces ClosedThanatermesis
100%
3.0 Task Description

Looks like when the partition label has a space, blocks e17

 559 2010-03-082017-08-25Bug Report hibernate wake-up problem ClosedRoman Vik
100%
3.0 Task Description

some problem with USB appeared after trying to wake up from hibernate.. Enumerate USB or something.. ?
System wont launch and the text with error report is running on the screen..

 558 2010-03-072017-08-25Feature Request Better Volume Control ClosedJared King
100%
3.0 Task Description

It would be nice to have better volume control uupon installtion. Maybe a switch on the desktop or better support for laptop volume hotkeys.

 557 2010-03-062017-08-26Bug Report Unexpected end of editing features - F1 recovery E17 er ...ClosedRoman Vik
100%
3.0 Task Description

If U end some dialogs from setup panel without exit as expected - for example not to wait for EXIT button and end it with close window or ESC, there is E17 error appeared..

 556 2010-03-062017-08-25Feature Request Upgrade system feature request ClosedRoman Vik
100%
3.0 Task Description

The needed “features” for upgrading system from ISO (CD or HDD ISO):

- let the gadgets be as they were before
- let the background be as it was
- lost the hotkey setup from the keyboard shortcuts made by myself
- lost the installed applications, they’re still on HDD but they’re not installed

 555 2010-03-062014-06-05Bug Report volume still setup to 100% after first install of Topaz ClosedRoman Vik
100%
3.01 Task Description

After upgrade system from ISO the volume setup to 100% - too loud for the first time..

 554 2010-03-062017-08-25Bug Report 2.0 : scrolling disabled with touchpad ClosedJean-Francois Blazy
100%
3.0 Task Description

Version 2.0 new kernel Topaz

laptop Dell Vostro13, touchpad synaptics, gsynaptics 0.9.14-6 installed

No scrolling at all with the touchpad (vertical, horizontal...)

tap is ok (double tap= 1 click)

It seems that’s it doesn’t work at all, when I try to load the touchpad menu, I get :
“Synaptics couldn’t initialize.
You have to set ‘SHMConfig’ ‘true’ in xorg.conf or XF86Config to use GSynaptics”

I’ve added these lines to the xorg.conf file, and also a shmconfif in hal (like in this doc : http://doc.ubuntu-fr.org/touchpad ...in french), reloaded the system and nothing (the ibar only disappear the 1st time...)

saw on some boards it could be a problem with the kernel (?)

 553 2010-03-062010-03-15Bug Report swedish boot option ClosedThanatermesis
100%
3.01 Task Description

<PrinceAMD> Thanatermesis, <Elive_user25_en> If one choose swedish as language in textmode boot.
<PrinceAMD> <Elive_user25_en> Everything is translated into...
<PrinceAMD> <Elive_user25_en> finnish.
<PrinceAMD> <Elive_user25_en> that has not one word in common with swedish

 542 2010-02-042017-08-26Bug Report tick mark in Screen Resolution Setting box is not being ...ClosedMichal/ Wernicki
100%
3.0 Task Description

After changing resolution or frequency with the Screen Resolution Setting box the tick mark doesn’t change it’s place. However it marks the proper option after closing and reopening this box.

Showing tasks 1 - 50 of 84 Page 1 of 21 - 2 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing