Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Installed Mode
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version 1.0 Gem (Stable)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Elive
Opened by Roger Gagne - 2007-07-06
Last edited by Thanatermesis - 2007-08-02

FS#129 - login user_password not accepted

at the login : the password given for the user is not accepted
roger126@sympatico.ca


Closed by  Thanatermesis
02.08.2007 04:07
Reason for closing:  Fixed
Additional comments about closing:  

Thanks!

Admin
Thanatermesis commented on 07.07.2007 09:28

Of course do you use Shift where is needed, correct ? (the system is case-sensitive)

What is the name of that user ?

James C. Bauernfeind III commented on 30.07.2007 15:43

I have the same problem with my install. Once in the live CD, I selected the install to Hard Drive option. It installed fine and walked through the standard questions about root password, and username and password. I set all this up. The install said it was complete. I rebooted, and Elive started on the HD (much faster BTW) and prompted for a username and password. I typed tutungzone, and pressed enter and it dropped down to the password line... I must have entered the password 10 times. Then I just hit OK with no password and it worked. Unfortunatly this is not the case for the root password. The root password is not blank... and it is not the one I chose or even the default Eliveuser password. Without being able to access the root account I cannot change the passwords, leaving me with a bricked computer at the moment.

I did notice that if it does not have a username in security it will not jump down to password. This is nice... but what I can’t understand is why or how would the system not record the passwords, yet it did record the username, even when you have to type the passwords twice?? Is there a quick way someone knows how to get in to the security table and update the permissions or something for the user that is working without root permissions so I can get this fixed without reinstalling? Let me know.

Admin
Thanatermesis commented on 30.07.2007 19:48

James no... its not nice, I mean, the user not works without password by default, what you* exactly have is a BUG, but I need to know WHY that bug exists, tests to do:

  • tell me what is the exact password used that not works
  • try to set the same password again to this user from elpanel
  • try to create a new user using this password (elpanel too)
James C. Bauernfeind III commented on 31.07.2007 15:07

Thanatermesis,

I cannot do anything from Elive Panel as it requires an Administrative password, which I setup in the install... but it does not work. I am unable to get into and change the passwords for any users or the administrative password... or even create additional accounts. Is there another way around this... like running the live CD again and trying to access it? The passwords that were used in the original setup are @li$8n for Root, and $t3r1in5 for the user. Niether of these passwords saved... yet the username did carry over as “tutungzone” with no password. If it was an error in the install with not liking the password, I would have thought that an error would be generated, but this was not the case. Let me know what I should try next. SHould I try reinstalling and see if it does it again?

James C. Bauernfeind III commented on 31.07.2007 15:16

Thanatermesis,
I launched elpanel from the console, and it launched fine. I select Admin and System Configuration, to get to the user setup... that works and brings me to the next screen. I then select Users Manager, and it will ask for the Admin password, but I also noticed in the Console window when I click on Users Manager that an error comes up stating “(gksu:3214): 6tk-WARNING **: Unable to locate theme engine in module_path: “experience”,”

Does this help any?

Admin
Thanatermesis commented on 31.07.2007 15:24

Problem found!
setup are @li$8n for Root, and $t3r1in5 for the user

You can’t use $ char, because on bash is interpreted like a variable and that confuses the system change manage the passwords

The more easy/fast thing that i recommend you to do is to reinstall without using $, I need to set up a system that advertice the user to not use this character, thanks for your report :)

James C. Bauernfeind III commented on 31.07.2007 15:30

Thanatermesis,
Is this just something with Debian? I have used “$” in Red Hat (CentOS) and even in XandrOS, which I thought was a Debian backend. I will do as you recommend and see if that helps. You may want to find a way to seperate passwords from Console functions as $ should not effect the way the system reads a password. Please keep me updated. I will reinstall and let you know. If it works I will create a user account with the same password and see what happens. Thank you for the QUICK response... you are the man!!!

Admin
Thanatermesis commented on 31.07.2007 16:22

Please wait for the reinstallation, im trying to fix that on the installer, i tell you on some minutes

James C. Bauernfeind III commented on 31.07.2007 16:27

LOL... too late, already reinstalled. I can easily reinstall again though, it is a clean and easy process, and I am using this computer only for it... so when ever you have it let me know, and I will test it for you. Thanks Again!

Admin
Thanatermesis commented on 31.07.2007 16:56

Ok, time to tests :)

  • Go to the liveCD mode and download this new installer modified: http://main.elivecd.org/tmp/eliveinstaller-3g_3.4-3_all.deb
  • use the file-manager for install it (see if the installation don’t give any problem
  • open a terminal, type su and type after eliveinstaller, if you have any kind of zenity error message, reboot and try those steps again
  • Install Elive to the hard disk (please use a separed /home partition), and use the $ value on your user/password, the installer is ready to use it now
  • reboot to the installed system and see if works
  • after the fine tune step, to dpkg-reconfigure -fnoninteractive passwd and report the possible error/message lines

If all is correct on this new installer version, the $ can be accepted now (the changer of passwords and users creator on elpanel aparently accepts $ by default), but maybe not works on a update mode installation (update mode installer works when you have a old Elive system in your computer with a separed /home partition), if you have it, please reinstall again (yes, after this new install), Elive in that update mode to see if the $ value on the user/pass still’s working

Tell me about the result of those tests for i commit this new installer with $ supported

If after your new system is installed, running, and correctly working with $ on your password, you see any future problem or strange thing, tell me

James C. Bauernfeind III commented on 31.07.2007 19:32

Testing....(Installer)

  • Got your post then cried ;)
  • Restarted into LiveCd, connected internet and downloaded and installed eliveinstaller.
  • No issues found in the installation of the new installer.
  • Started EliveInstaller from Console - Prompted to say it is a Development Version
  • I already had partitioned to have /, and /home partitions previously - Installer began installing to Hard Disk
  • Watched Console for errors... did not see any.
  • Used $ in the password for root and user account, no errors seen so far
  • Restarting

Testing....(Installed)

  • Elive started up fine and went to login screen
  • used tutungzone as username
  • used $t3r1in5 as password... it said password is incorrect
  • tried root and password @li$0b... is said the password was incorrect.
  • Does not look like it worked.

Thanatermesis... it looks like the development version of the installer made no difference, the $ still seems to be unusable.

I also tried the same steps above except going through the upgrade, and same result. The new installer has no effect on the use of $ in the password.

Thanks!!

Admin
Thanatermesis commented on 01.08.2007 15:37

I’m sorry, the installer that I have uploaded is with the old code, that’s why not has worked. I have upload that new installer to http://main.elivecd.org/tmp/eliveinstaller-3g_3.4-4_all.deb , please try again with this one

James C. Bauernfeind III commented on 01.08.2007 15:43

Ok... give me a little while and I will rerun the new installer and let you know. Thanks again!!

James C. Bauernfeind III commented on 01.08.2007 18:24

Testing....(3.4-4_all Installer)

  • Install went fine
  • No issue with assigning $ in passwords

Testing....(After Restart, Elive Installed)

  • Logged in fine with $ in both user and root passwords
  • Ran Auto configuration fine

Testing....(3.4-4_all Installer - Upgrade)

  • Installed fine, no issue holding old passwords
  • Worked fine after reboot

Looks good so far!! I will let you know if I run into anything else. I may post another thread for Intel Wireless 2200B/G cards. (The system sees the card, but when trying to activate the card, it times out). May want to see about adding a utility that searches for Wireless access points, and auto configures.

My System:
Dell X200 Laptop
800Mhz P3M
384Mb Ram
40Gb HD
Intel 2200B/G Wireless
Intel NIC

So far everything except the WIreless card is working...

Thanks again Thanatermesis!!!

James C. Bauernfeind III commented on 01.08.2007 18:43

Also... did the “dpkg-reconfigure -fnoninteractive passwd” and had no issue. Shadow passwords enabled fine.

Thanks!!

James C. Bauernfeind III commented on 01.08.2007 19:47

Also... did the “dpkg-reconfigure -fnoninteractive passwd” and had no issue. Shadow passwords enabled fine.

Thanks!!

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing