Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Installed Mode
  • Assigned To
    Thanatermesis
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version 1.0 Gem (Stable)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Elive
Opened by JB - 2007-07-10
Last edited by Thanatermesis - 2009-02-02

FS#135 - Elpanel not working unless logged in as root

I’ve installed Elive on an old Compaq P3 @700 Mhz, with more than 128Mb of memory.
The problem is that running as another user than root doesn’t allow the access to the elpanel.

The problem happened as soon as installed was completed, when I logged in with the user created during installation.
The ‘fine tune’ step seems to start, however I’m not able to confirm it does anything, neither if it ends after a while.

When trying to access an option in the elpanel, I get the prompt for the root account password.
If I enter a wrong password, the windows pops up again requesting the password.
If I enter the right password, the windows closes, but nothing happens.

I tried to login as root, and I have full access to the panel (even if I loose all my icons and bars).
I’ve tried to delete and create new users, but it still doesn’t work.

I’m quite a noob in Linux, but I don’t think I made a mistake (in fact I followed the installation step by step).
My drive is a 10Gb, split in one main partition of 7.5Gb for the system, and a 2.5Gb Linux-swap.
I’ve used the reiserfs format as suggested.

Please if I missed anything just tell me ^^
Thanks in advance for your suggestions.

Closed by  Thanatermesis
02.02.2009 02:14
Reason for closing:  Fixed
Admin
Thanatermesis commented on 24.07.2007 13:23

What is the exact name of your user that has this problem ?

What happens if you launch elpanel from a terminal ? what error messages you got after to put the password of root ? (messages on the terminal)

Admin
Thanatermesis commented on 24.07.2007 13:43

I have ear something similar to that but due to a modified (fake) Elive ISO from torrent, maybe you are using this one ?

phil commented on 05.08.2007 18:43

Hi I have the same problem on desktop PC with official elive gem.
Fresh install did not work - root password has no effect.
re-installed but kept home directory, problem persists.

Installed from same CD-Rom on a Dell Laptop - works OK.


phil commented on 05.08.2007 19:24

ok this is the print out from terminal when launch elpanel...

Edje launcher

518 320

(gksu:3434): Gtk-Warning ++: Unable to locate theme engine in module_path: “experience”,
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

(keybconf.bin:3448): Gtk-WARNING ==: cannot open display:

Ok hope this helps to solve the problem, any advice appreciated!

Admin
Thanatermesis commented on 07.08.2007 11:27

do you have used the value $ (dollar) on your password of root ?

JB commented on 07.08.2007 11:42

Hi everybody!

A workaround for this issue was provided on the Elive chat chanel (the one you get whet launching the app).

I have to type “xhost +” in a terminal before running the panel and it works fine.
I type again that aftewards, which isn’t that boring as in that way the users aren’t able to change anything :D
Regarding the answers:
1: The user is a normal user (not root). Launching the panel from a terminal causes the same issue.
2: I had this version from a torrent link. Maybe its a modified, I don’t know.
3: Password is quite simple, no special characters

Admin
Thanatermesis commented on 07.08.2007 11:56

Do you have done successfully the fine-tune step after the installation ?, I think that the problem is from here... open a terminal with root and do: dpkg-reconfigure -fnoninteractive -a, reboot and try again

JB commented on 07.08.2007 15:54

Ok I will try.
I think indeed this step cuased some issues as typing installation and admin tasks aren’t functionnal unless I type “xhost +” in a terminal prior to do anything.

phil commented on 07.08.2007 19:43

Ok

1. I haven’t got $ (dollar) sign in any password.

2. When booting shows fine-tune setup - enter root password - get nothing.

3. Ran this command as root - ‘dpkg-reconfigure -fnoninteractive -a’ - did that seamed to work but messed up video driver, still asking to do fine-tune setup on reboots.

4. Using ‘xhost +’ in a terminal does work

So how should I go about getting my nvidia graphics driver back?

Cheers

Admin
Thanatermesis commented on 08.08.2007 17:05

phil: ok, with your point 2 seems like that the root password is not accepted from the first time (fine-tune step), then aparently your root password simply “not works”, try to open a terminal and type su, it asks about the root password, check if works at least on that way, if not, I need to know your exact root password, maybe contains a invalid character or not accepted one, i need to make tests using your password

3) yes, a configuration of the video-driver is made on this step, in mplayer (gmplayer) more exactly, for check the exact problem, first of all, do those steps:

  • create a new user from elpanel (well, when you can enter the password of root, of course)
  • from root, edit the file /home/yournewuser/.elxstrt and remove the line postinstall-user
  • login on X with your new user, check if the videos can plays (mplayer/gmplayer), clicking on a video the filemanager is good too
  • if the videos plays correctly (and pressing the F you get a correct fullscreen/zoom mode), copy the mplayer configuration dir: cp -r .mplayer .mplayer.test1
  • launch the command postinstall-user and check the video again, aparently now it not works, do: diff -r .mplayer.test1 .mplayer » differencies.txt, attach this file differencies.txt here or paste it on the comment
  • i need also the result of: xvinfo > xvinfo.txt, attach xvinfo.txt too

I’m not sure if this is the exact problem that you have on the video stuff or its due at dpkg-reconfigure -fnoninteractive -a step, but maybe I need more info, can you join the #elive channel at freenode and give me a ssh login for check better what happens ?

JB: Show me your exact root password too, I still thinkin that’s a problem in the chars used on it (maybe ‘!’ ?)

phil commented on 08.08.2007 17:36

Hi Thanatermesis,

Root password does work ok in terminal by doing the SU command.

Root password = 4549star

I restored the xorg.conf file from a backup copy and got nvidia driver back and fully working.

so I still cannot get rid of the fine-tune on bootup, and I have to run elpanel from terminal via SU command.

Regards


Admin
Thanatermesis commented on 08.08.2007 18:04

Your root passwords seems perfectly correct, but try to change it, open a terminal and type su, then type passwd, put a new password with only letters (no numbers), very thing like abcdefg, simple, and try if works when you launch elpanel things, if works, change the password again to the old one 4549star and see if works now

phil commented on 08.08.2007 21:58

Hi Changed the password to abcdefg but sorry to say it didn’t work. :(

Admin
Thanatermesis commented on 08.08.2007 23:53

That sounds finally ugly, I need to know from where is the problem but I don’t know the way to do it from here, maybe you can enter on the #elive channel at IRC ? (open Xchat at your dock, 2º icon by default)

Do you have do any “different” thing on your Elive system than the default system ? (like copying files of a old /etc, use a old /home manually, etc etc)

Admin
Thanatermesis commented on 08.08.2007 23:54

Do you have chaned Entrance by other login manager or something similar ?

try dpkg-reconfigure x11-common and select “everybody”

Cameron Meikle commented on 21.08.2007 19:33

I too am noticing this problem, with the development elive from http://elive.homogenica.com/development/elive_0.6.9_unstable.iso, in case that helps out finding a bad apple...
I downloaded it yesterday evening Monday Aug. 20th and ran a typical install.

On first boot-up of the live cd, I couldn’t get the network to start, meaning I had no internet. I found the elpanel, but every time I tried to run the net config, it asked for a root password, which I provided it, the it blinked at me, and I was staring at the elpanel again. After trying several times, I even tried the live disk password, getting a password error... I then logged in as root and ran the elpanel network setup from there, where everything worked. After getting it to work here, and poking around, I installed freecraft using synaptic and ran it, then, realizing how nice everything else worked, I decided this was definitely worth the install.

I had partitioned my drive for a Mepis Linux install, which I replaced with Elive, using only One existing partition instead of the suggested extra partition for ‘home’. I also formated it with reiserfs as suggested during install.
After finishing the install, I found myself with the same trouble with elpanel :S I fixed it the same way as I had with the disk, and now the network seems to start automatically on bootup.

I feel silly realizing I could have just su ‘d to root, which I’ve now tried in terminal with success. It accepted my password there, and Elpanel then works fine... As an experiment, in panel from my user account, I typed elpanel, it opened, then I tried to access the network setup, I got, um, hey, I just found out that you can’t copy and paste terminal contents! Another thing to fix? :S

epanel

Edje launcher

518 320
Xlib: connection to “0.0” refused by server
Xlib: No protocol specified

Xlib: connection to “0.0” refused by server
Xlib: No protocol specified

(network-admin:3593): gtk-warning ++: cannot open display:

A very quick blink of something on the screen, then you are staring at the elpanel again, with no network config happening. I tried almost all the elpanel functions, with similar results, the login won’t work from the user, meaning accessing the elpanel from the GUI won’t work for all those newbies out there, (I almost classify as a newby as well, I only know so much about Linux and all the details don’t seem to stick.)
I hope what I’ve written helps you with this problem, the elpanel is such an elegant solution to be encumbered with a terminal window login being required!

Thanks for the advice, it works, and I love what you are achieving with this distribution, though it’s got a few rough edjies, it’s a diamond in the rough!

Admin
Thanatermesis commented on 23.08.2007 09:40

Maybe that’ is the more ugly bug that i have found on Elive, but I think that i can imagine what are happening... because

  • The root password works correctly (you can su on a terminal and after enter it, you have root correctly)
  • The fine-tune step has never done correctly, this is why is possible to that problem happens

I need to know if this solution solve’s the problem:

  • Do a new installation of Elive, but on the first boot of the installed system, when asks about the fine-tune step, just Cancel it
  • Open a terminal and launch cream $HOME/.elxstrt from user, and before the line postinstall-user add a line that contains xhost + , save the file and reboot computer
  • After the reboot and login from user to the graphical system, do the fine-tune step, this time needs to be launched correctly (or at least this is the idea), and no like’s phil says on a before comment: 2. When booting shows fine-tune setup - enter root password - get nothing.
  • Reboot again after the fine-tune step is finished, this time when you launch elpanel, needs to be work correctly
  • don’t forget to open again the cream command and remove the xhost + line of your .elxstrt file

Please anybody try this solution and tell me if solves the problem for fix it directly on the installer


Nigel commented on 06.12.2007 17:12

I originally was having problems with the fine-tune step and I managed to get it launched manually through the terminal, but I still needed to log in as root and launch a lot of the elph panel programs manually through the terminal because when launched through the panel, it asks for root password, and then nothing happens after you proceed.
However, your solution worked for me Thanatermesis.
I reinstalled eLive 1.0 and followed your instructions given above. It worked and loaded up the fine-tune step after adding xhost+ and rebooting. I can launch things through the panel and everything seems to be working great.

Nigel commented on 06.12.2007 18:24

I guess I spoke to soon, I don’t know if i was imagining things last night, but I thought the elph panel was working fine. Rebooted this morning and tryed using it again, have to log in as root and use terminal to launch specific panel apps.
So your solution fixed the fine-tune step, but not the panel problem, at least for me.

Admin
Thanatermesis commented on 06.12.2007 19:35

What happens if you launch elpanel from a terminal from user ? do you have any message ?

Can you possible to try the new development version ?

Nigel commented on 06.12.2007 23:24

I launched elpanel from the terminal. It launches. This is what it says in the terminal:

Edje launcher

518 320

I tried to edit the time configuration from the panel. It asks for admin password. I enter it, and then it never launches. From the terminal I got this message:

xlib: connection to “:0.0” refused by server

xlib: No protocol specified

(time-admin: 3519): Gtk-WARNING **: cannot open display:

This message pops up for almost everything I open through elpanel (with the exception that “time-admin:3519” is replaced by the name of whatever I try to open.

Would you recommend the new development for full-time use? I have it burned I just haven’t got around to trying it out.

Admin
Thanatermesis commented on 07.12.2007 17:14

its a very strange problem that I have see very time ago... seems like a problem of permissions with the user, tell me, is this user from a old other OS ? maybe a /home imported or something ?

try: strace -o strace.log elpanel and attach here the file strace.log

North commented on 10.01.2008 18:06

I might be late with the info, but I had the same problem and I did this to solve it..

Log in as user name
Cancel the Fine-Tune setup operation
Opened a terminal window/log in as root
Navigate to the following folders (usr/bin/)
Type: postinstall-user (then hit enter) and the installation will begin in another terminal window..

Admin
Thanatermesis commented on 10.01.2008 18:16

What I need to know to fix the bug is... after the fine-tune step do manually, the problem is solved ? (on elpanel for example, when request the root passwords seems like to fails there too)

Admin
Thanatermesis commented on 11.01.2008 13:14

Maybe can be solved with the command echo -e “xhost +” » $HOME/.elxstrt from user in a terminal, before of the fine-tune step, works

The problems seems to be on the gksu package from debian

Richard commented on 29.01.2008 03:03

“Comment by Thanatermesis (thanatermesis) - Thursday, 23 August 2007, 05:40 GMT-5

Maybe that’ is the more ugly bug that i have found on Elive, but I think that i can imagine what are happening... because

The root password works correctly (you can su on a terminal and after enter it, you have root correctly)

The fine-tune step has never done correctly, this is why is possible to that problem happens

I need to know if this solution solve’s the problem:

Do a new installation of Elive, but on the first boot of the installed system, when asks about the fine-tune step, just Cancel it

Open a terminal and launch cream $HOME/.elxstrt from user, and before the line postinstall-user add a line that contains xhost + , save the file and reboot computer

After the reboot and login from user to the graphical system, do the fine-tune step, this time needs to be launched correctly...”

I also had this problem with GEM 1.0, and then followed this advice from Thanatermesis and at least in my experience I can say that this proposed solution worked for me.

Admin
Thanatermesis commented on 02.02.2009 02:14

Well, actually this bug not happens anymore on newer versions of Elive since we use our own “gksu” system (esu), so i close this bug :)

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing