Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Any
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 2.x (beta's)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Elive
Opened by JF Bourdeau - 2018-06-25
Last edited by Thanatermesis - 2018-06-25

FS#697 - Being to run Elive at it's full GUI potential within a VM allowing easier product review

A lot of Techies doing reviews are using Oracle virtual box to try new OS and to make reviews.

I don’t know all the technical reasons behind it but why Elive cannot run at it’s full " Visual effects potential” within a VM ?

In my case I started products review project in french ( a new project I have on " Patreon”) and even if I was blown away by ELive, THe fact that I can’t show Elive at it’s Full potential when runned within a VM, I have delayed my review of Elive.

My simple tought was " I’ll find a time to install it on a real PC” and use Vokoscreen already within Elive but.... I don’t have that many PC’s :-) (3 : one to run my TV (ubuntu budgie), one on my laptop for work (EndlessOS as the HP stream is kind of slow... Ia tried Elive but was having problem with TouchPad ) and one on my desktop (that for now I want to keep it with the actual Linux distro...)

So even if the performance is not good, if it is technically possible for you to let Elive install itself " with it’s full GUI power " (sorry don’t know how to call it) within a VM, for sure I would do a french review and post it on my Patreon page, and on my LinkedIn Wall (18.000 connections). May be others Nerds would also make review of it on their Youtube channel / web site...

As I am impressed by ELive GUI when activated at it’s full potential, when installed on a real machine, I don’t want to record a video of the " Virtual BOx version of elive”.

JF

Closed by  Thanatermesis
25.06.2018 22:29
Reason for closing:  Not a bug
Admin
Thanatermesis commented on 25.06.2018 16:39
I don’t know all the technical reasons behind it but why Elive cannot run at it’s full " Visual effects potential” within a VM ?

Because "visual effects" (ecomorph/compiz) requires 3D/GL accelerated features which are not available (not working correctly in virtual box), same for "hardware accelerated" desktop (which is an option that doesn't appears in vbox but it does in normal computers)

So it can perfectly work (and install) using rendering composite in software mode (which is the default setting that will be set automatically for vbox), but you lack a faster desktop experience and all the special effects (like the 4 buttons in the right from the hidden-extra-menu in the borders)

BTW I don't like to write long texts but i think that is a good idea to make that message more descriptive, so I have just changed it from:

Your experience with Elive in a Virtual Machine will be more limited, there's an impact on speed and features like rendering options, extra visual effects are also not possible. Please consider to give it a try in a real hardware.

to:

Virtual Machine: Your experience with Elive will be more limited, due to not having a real accelerated graphic card you will not have the visual effects available, the composite desktop will also render via software, lacking extra features like the ones from the four buttons in the hidden menu of the window borders. By other side it will work without any problem and can be installed too. Please consider to give it a try in a real hardware to unleash all the features.

Suggestions?

JF Bourdeau commented on 25.06.2018 18:58

OK I get it.... So the only way for now to try 100% of your amazing interface, is really to try is from the USB Stick or install it onto a PC..
Tks for your patience...

Admin
Thanatermesis commented on 25.06.2018 22:28

Well, installing in the virtualmachine won't enable the features, the limitation is in the virtual machines themselves. But yeah, just run it from an USB in a normal computer :)

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing