• Status Closed
  • Percent Complete
  • Task Type Bug Report
  • Category Any
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version 3.0
  • Due in Version 3.x (beta's)
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Elive
Opened by stoppy98 - 2018-09-10
Last edited by thanatermesis - 2020-02-01

FS#721 - Old, unsupported graphics

I’d liked to test elive’s minimum requirements putting together some of the oldest piecies of hardware i have lying aroud.
I begun trying it out with a old motherboard, a sf2/661fx rev 1.1, which features sis integrated graphics/sis 964l (which is pretty common in old pentium 4 based office desktop computers), mounting a ‘01 2.44 GHz pentium 4 (https://ark.intel.com/products/27438/Intel-Pentium-4-Processor-2_40-GHz-512K-Cache-533-MHz-FSB), 512 mb 266mhz ddr ram and a classical ide hdd.
It looked like a possible common set up for older computers, and i was surprised finding out that there was no way to boot in graphical mode! None of the options given, either in pae or older kernel, not even the special graphics failing mode!
Then i added a vanta 16 (which i noticed in here was a often times used cheap af graphics card in older pentium 4s, as it was the msi nvidia tnt2 riva m64/m64 pro, which gave me the same results as the vanta being based on the same hw/drivers). Despite if i’m not mistaken it was supposed to support 76xx drivers (which should be avaialble in the repos), i needed to switch to the free drivers. It let me choose keyboard language and system language correctly., then when getting to the desktop it gave me a black screen :/ the mouse was visible though, so i think there must be a workaround (i will try to find it as soon as i have time)
then moved to geforce 2 mx200/mx400. Supposed to work fine with either legacy drivers 76xx or 96xx, both gave me several graphical errors. nosense screen resolution (like 600×480) and i was unable to use either the dock or the applications menu. Terminal took forever to open and everything was mostly unusable. Tried again with all the boot options, looks like working fine only using the free drivers options (both with the newer and older kernel). No graphics acceleration available, even if in windows 98 graphics acceleration was available.
Using the software acceleration caused a heavy load on the poor p4, which meant random freezes whenever it had to open an heavy application/installing something with apt-get (and the bottleneck wasn’t the ram or some sort of swapping, never hit 300 mbs of used ram!). Tried switching to e16, nothing changed.
The machine worked perfectly (and same for all the graphics options listed here)under windows 98/xp and debian stretch with i3-wm. Only issue was the sis chipset unable to elaborated 3d graphics for a lack of compatible drivers in linux, but i’ve been running q4os (debian jessie, later stretch, + TDE at the time) without having too much troubles. DE worked perfectly, at least

Closed by  thanatermesis
01.02.2020 17:43
Reason for closing:  Fixed

The package xserver-xorg-video-sis* is installed by default in Elive 3.0, it is strange that it doesn't works for you

Not sure which package should be needed for vanta

About the nvidia 76xx version, it looks like it is too old and doesn't compile with that kernel (nor newest ones), if im not wrong it is not available anymore at all: https://packages.debian.org/search?keywords=nvidia

about the black screen for that nvidia mode, it can be due that you have selected the accelerated mode enabled (try without it), or because of the ecore_sync: to try this one, boot in "console mode only" without graphical system, then in your login shell try to run the command:

    export ECORE_NO_VSYNC=1 ; startx

This is a very detailed and useful report what you did, unfortunately these old drivers will probably work better in the older versions of Elive, which I strongly suggest you to try the Topaz or even the Gem versions that you can found in: https://www.elivecd.org/download/old-versions/

By other side it is very interesting that you tried with stretch and it worked good for you, this meants that a future version of Elive based in newer packages will work better on these machines, I will be happy if you can betatest the future beta versions before the next future stable release :)

Project Manager

Thank you for your attention to this post.
I will try to follow your advice and of course I'd be happy to beta test the future beta versions!

Project Manager

Everything works perfectly with the last beta. Writing this answer on that computer rn!

Date User Effort (H:M)
watch my effort tracking timers


Available keyboard shortcuts


Task Details

Task Editing