Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Live Mode
  • Assigned To
    Luis Lopez
  • Operating System All
  • Severity Low
  • Priority Medium
  • Reported Version 3.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Elive
Opened by Thanatermesis - 2019-05-02
Last edited by Thanatermesis - 2019-05-04

FS#731 - Failsafe mode needed to boot or black screen appears

Hi Luis,

I added this issue in order to know what is the cause that the other options gives you a black screen

To install in failsafe mode could remove some features so if you are able to install it in normal mode it could be better, so let’s investigate the cause

Closed by  Thanatermesis
04.05.2019 12:17
Reason for closing:  Fixed
Admin
Thanatermesis commented on 02.05.2019 16:24

First: try to boot the Live mode and in the boot menu press "tab" to edit the options (esc to return to the menu), on it you can try to remove the "splash" entry and also add "vga=normal", let's see if these options in the normal boot makes you reach the graphical system without issues

Luis Lopez commented on 02.05.2019 16:38

Hello again, I'll try to explain me as best as possible:

1.- I start with USB stick in Live mode in a normal way (default way in Live USB system), no problem at these way, USB stick start in normal mode with no problems. I can work with USB stick completely.

2.- At that moment, I chose to instal Elive in my HDD, installer runs and at the end, when my computer restart I listen the start music but screen is black. If I force a reboot and boot in safe mode it start in console mode as root. I write "startx" and GUI started normally. If I reboot again, I have always black screen as many times as I reboot.

3.- So I start again the Live USB stick system but this way in "safe mode - old computers", and the I install Elive in my HDD. Only with these way I can start GUI normally.

4.- I have my documents in an isolated HDD partition so I can install Elive as many time as necessary, so, if you agree, I'll start Live system with vga=normal and removing splash, it's OK?

Waiting for your answer.

Greetings.

Luis

Admin
Thanatermesis commented on 02.05.2019 16:49

Thanks for the info, first I thought that the problem was with the Live system specifically, but aparently the Live mode works correctly and then it fails after to install ?

In such case, reinstalling at this moment like i explained before won't change anything right now

Question: does the normal boot of the live mode shows you any message in the screen before the graphical system launches ? something about ECORE or "restarting attempts", or any message in the launched desktop, or if the Screen try's to show something and returns back to console and then runs again (attempts of making working the graphical system)

Try to see if you have this file after the desktop launched in Live mode:

cat /tmp/.X11-error-logs-to-user

The thing is that: if the Live mode worked but not the install (with the first option), then something (good) happened in the Live mode (like fallback options and extra configurations when it fails) which needs to be included in the installed system too

You have a spanish name, are you from barcelona? (just in case you are near here :))

Luis Lopez commented on 02.05.2019 17:01

Yes, normally Live mode works correctly, but install from gives the black screen.

I'll reboot in Live mode and say you later, I remember one of two times live mode frozen while starting but I doesn't remember the message in frozen screen, I'll take a look and say you in a few minutes.

I'm effectively a Spanish guy, but actually I live in France (so we aren't nearby, sorry) and I'm looking for a job in Belgium ;-) I'm from Granada and I lived in different cities in Spain like Valencia or Zaragoza. My Vespa P200 I bought it in Barcelona, and I goes there sometimes in 2000/2001 year.

I'll reboot in Live (normal) mode with my USB stick and say you the result ASAP

Luis Lopez commented on 02.05.2019 17:27

Hi,

My computer seems doesn't start from USB stick (and last Monday it does), as I doesn't made many BIOS changes, maybe my HW starts to fault?

I hope you doesn't work for nothing. I'll look for some HW test that I remember I saw in your website or in Elive system to run them.

Admin
Thanatermesis commented on 03.05.2019 00:19

3.0.5 available for download with all the small issues fixed!

Luis Lopez commented on 03.05.2019 07:18

Hello Samuel,

I’m downloading it actually, I'm working with 3.0.4 in a "new" old laptop Acer Aspire 5310 from 2007 without problems.

I'll try 3.0.5 release at it ASAP and I'll let you a remote access to HP if you want for make test that may help you to understand the bug (if it's really a bug, because I think probably in a HW fault)

I'll wait for your instructions if you agree.

Have a nice day.

Luis

Luis Lopez commented on 03.05.2019 12:46

Hello,

With installation of 3.0.5 release this issue has been fixed. I can start Live USB system in normal mode (but not activate acceleration nor special effects to avoid my screen frozen because my graphic system doesn't support acceleration). Message says something like: "Your screen driver doesn't support OpenGL or none OpenGL engine has been compiled or installed for Evas or Ecore-Evas. Coming back to software engine"

After installing and reboot without USB flash memory system starts OK, black screen has disappeared.

I precise I have done a NEW installation (not un update) of 3.0.5 release leaving Elive make a HDD intelligent partitioning (so all my HDD old partitions has been removed) and employing reiserfs.

For me this issue seems to be solved.

Thanks a lot and have a good week-end.

Greetings.

Luis

Admin
Thanatermesis commented on 03.05.2019 22:36

Thanks for the tests, Acceleration (gl) can be possible that doesn't works due to the old drivers, so next beta's will have htem updated

Actually Im a bit confused about "which machine" is each of these 2 bug reports, if the Acer or the HP :), so tell me which issue i should close if the bug is fixed, of if this one is the one having the (possible) hardware problems with the crashes

Note: you can run composite (no special effects) in software mode, this is the setting recommended if GL mode doens't works

Luis Lopez commented on 04.05.2019 10:10

Hello Samuel,

First of all, it's a pleasure to make test if those can help you ;-)

Second, the only machine involved in both bugs it's the HP, ACER it's an old laptop that gets hot a lot (even with an external fan support) that I used as second machine to work while HP crashes. Both machines had Antix Linux until I discovered Elive 15 days ago. Now both machines runs Elive. So for our investigations Acer never exists. I'll use it only if you need to run special test in HP or if HP crashes to continue my daily work as job seeker :-(

You can close this issue (#731) and let the other open at least one week (I work everyday with the HP, so I think one or two weeks are enough to see if bug it's solved, now it seems because I'm writing this thread with HP without problem.

I propose you to close this issue #731 and pass issue #730 in private mode to discuss in Spanish, it will be easier to me explain all historic in Spanish than in English (I have had a lot of problems to install Elive 3.0.3 (first release I downloaded 15 days ago) in that machine (the HP always). One time all test performed we can open again the issue thread public and explain the result in English for everybody.

See you in #730 issue thread.

Thanks again, and have a good week-end (here it rains, I hope at Barcelona it's sunny).

Luis

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing