Elive

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Live Mode
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version 3.x (beta's)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Elive
Opened by Kirk Martin - 2020-03-12
Last edited by Thanatermesis - 2020-03-28

FS#747 - No wifi support

Trying to install Elive 3.8.9 beta and get message of no wifi drivers found.This is a HP Envy x360 convertible laptop.This is the output of my wireless interface.

*-network

     description: Wireless interface
     product: RTL8822BE 802.11a/b/g/n/ac WiFi adapter
     vendor: Realtek Semiconductor Co., Ltd.
     physical id: 0
     bus info: pci@0000:02:00.0
     logical name: wlo1
     version: 00
     serial: 40:5b:d8:29:ed:ad
     width: 64 bits
     clock: 33MHz
     capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
     configuration: broadcast=yes driver=rtw_pci driverversion=5.3.0-40-generic firmware=N/A ip=10.0.0.38 latency=0 link=yes multicast=yes wireless=IEEE 802.11
     resources: irq:50 ioport:f000(size=256) memory:fe600000-fe60ffff
Closed by  Thanatermesis
28.03.2020 00:10
Reason for closing:  Fixed
Additional comments about closing:  

fixed / solved generically with a temporal link to this file from elive-udev package

Admin
Thanatermesis commented on 27.03.2020 18:47

Hi Kirk,

Thanks for reporting the issue, seems like this driver should correctly work on the last beta version of Elive, so the firmware seems to be included in the package firmware-realtek which you should have installed by default

Please check your dmesg info to search any possible error about firmwares and know where the issue is, like:

 sudo dmesg | grep -i firmware
 sudo cat /var/log/kern.log | grep -i firmware
 sudo cat /var/log/syslog | grep -i firmware

also try:

sudo mkdir /lib/firmware/rtw88 ; cd /lib/firmware/rtw88 ; sudo ln -s ../rtlwifi/rtl8822befw.bin rtw8822b_fw.bin

and then reboot, this may problably solve the issue

have you tried to run the other kernel? seems like this driver works good with it

please tell me which solution worked for you

Kirk Martin commented on 28.03.2020 00:04

Thank you for the reply.
I let the ISO fully install without internet connection then ran the second suggestion you said to try.
I ran the commands in terminal then rebooted and have wifi up and running now.
Using the 5.4 kernel.
Very nice OS so far,now time to play and check out all the features.

Thanks again,
Kirk

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing